Brad Bishop | 4aa3a50 | 2015-10-29 23:35:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC BT to DBUS" |
| 2 | DESCRIPTION = "Phosphor OpenBMC BT to DBUS." |
| 3 | PR = "r1" |
Matthew Barth | 1292be0 | 2016-11-08 10:04:56 -0600 | [diff] [blame] | 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
Brad Bishop | 4aa3a50 | 2015-10-29 23:35:38 -0500 | [diff] [blame] | 6 | |
Joel Stanley | cdb3268 | 2016-11-10 22:21:10 +1030 | [diff] [blame] | 7 | inherit autotools pkgconfig |
Brad Bishop | f65b562 | 2016-08-30 14:57:08 -0400 | [diff] [blame] | 8 | inherit obmc-phosphor-dbus-service |
Brad Bishop | 4aa3a50 | 2015-10-29 23:35:38 -0500 | [diff] [blame] | 9 | |
Brad Bishop | f65b562 | 2016-08-30 14:57:08 -0400 | [diff] [blame] | 10 | DBUS_SERVICE_${PN} = "org.openbmc.HostIpmi.service" |
Brad Bishop | 4aa3a50 | 2015-10-29 23:35:38 -0500 | [diff] [blame] | 11 | |
Brad Bishop | a715681 | 2016-09-06 22:02:03 -0400 | [diff] [blame] | 12 | PROVIDES += "virtual/obmc-host-ipmi-hw" |
| 13 | RPROVIDES_${PN} += "virtual-obmc-host-ipmi-hw" |
Brad Bishop | a6ec1d5 | 2016-09-08 17:09:18 -0400 | [diff] [blame] | 14 | RRECOMMENDS_${PN} += "host-ipmid" |
Brad Bishop | 4aa3a50 | 2015-10-29 23:35:38 -0500 | [diff] [blame] | 15 | |
Joel Stanley | cdb3268 | 2016-11-10 22:21:10 +1030 | [diff] [blame] | 16 | DEPENDS += "autoconf-archive-native" |
Brad Bishop | f65b562 | 2016-08-30 14:57:08 -0400 | [diff] [blame] | 17 | DEPENDS += "systemd" |
| 18 | RDEPENDS_${PN} += "libsystemd" |
| 19 | |
Brad Bishop | 4aa3a50 | 2015-10-29 23:35:38 -0500 | [diff] [blame] | 20 | S = "${WORKDIR}/git" |
Chris Austen | 652fee8 | 2015-11-24 22:04:53 -0600 | [diff] [blame] | 21 | SRC_URI += "git://github.com/openbmc/btbridge" |
Joel Stanley | cdb3268 | 2016-11-10 22:21:10 +1030 | [diff] [blame] | 22 | SRCREV="68bcce035ac7029d3110b53fb07848067da56b40" |
Brad Bishop | 4aa3a50 | 2015-10-29 23:35:38 -0500 | [diff] [blame] | 23 | |
| 24 | # This is how linux-libc-headers says to include custom uapi headers |
Joel Stanley | cdb3268 | 2016-11-10 22:21:10 +1030 | [diff] [blame] | 25 | CFLAGS_append = "-I ${STAGING_KERNEL_DIR}/include/uapi" |
Patrick Williams | efe8707 | 2016-06-21 12:57:28 -0500 | [diff] [blame] | 26 | do_configure[depends] += "virtual/kernel:do_shared_workdir" |