Lei YU | 4d8175e | 2019-10-21 10:39:07 +0800 | [diff] [blame] | 1 | SUMMARY = "Phosphor Power services and utilities" |
| 2 | DESCRIPTION = "Configure and monitor power supplies, power sequencers, and \ |
| 3 | voltage regulators, and analyzes power devices for faults" |
| 4 | PR = "r1" |
| 5 | PV = "1.0+git${SRCPV}" |
| 6 | |
| 7 | inherit meson |
| 8 | inherit pkgconfig |
| 9 | inherit systemd |
| 10 | inherit pythonnative |
| 11 | |
| 12 | require ${PN}.inc |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | # TODO: in future when openpower-dbus-interfaces is removed from |
| 17 | # phosphor-power, remove the dependency here. |
| 18 | DEPENDS += " \ |
| 19 | phosphor-logging \ |
| 20 | openpower-dbus-interfaces \ |
| 21 | sdbus++-native \ |
| 22 | sdeventplus \ |
| 23 | nlohmann-json \ |
| 24 | " |
| 25 | |
| 26 | SEQ_MONITOR_SVC = "pseq-monitor.service" |
| 27 | SEQ_PGOOD_SVC = "pseq-monitor-pgood.service" |
| 28 | PSU_MONITOR_TMPL = "power-supply-monitor@.service" |
| 29 | SYSTEMD_SERVICE_${PN} += "${SEQ_MONITOR_SVC} ${SEQ_PGOOD_SVC} ${PSU_MONITOR_TMPL}" |