blob: f014f1751175aa4788dd3b30a1a3f305a3166f05 [file] [log] [blame]
Brad Bishop667938f2017-01-12 21:44:51 -05001SUMMARY = "OpenBMC - Applications"
Brad Bishop93fb5352015-09-09 03:59:20 +00002PR = "r1"
3
4inherit packagegroup
5inherit obmc-phosphor-utils
6inherit obmc-phosphor-license
7
Brad Bishop93fb5352015-09-09 03:59:20 +00008PROVIDES = "${PACKAGES}"
9PACKAGES = " \
Brad Bishop46631702017-03-01 16:16:06 -050010 ${PN}-bmc-state-mgmt \
11 ${PN}-chassis-state-mgmt \
Brad Bishop6165ec32016-09-06 22:44:21 -040012 ${PN}-extras \
13 ${PN}-extrasdev \
Adriana Kobylak0bce5322017-11-09 10:39:02 -060014 ${PN}-extrasdevtools \
Brad Bishop11909e02017-05-01 11:54:34 -040015 ${PN}-fan-control \
Brad Bishop46631702017-03-01 16:16:06 -050016 ${PN}-host-state-mgmt \
Brad Bishop45f8b572017-02-01 21:04:14 -050017 ${PN}-inventory \
18 ${PN}-leds \
19 ${PN}-sensors \
Gunnar Millsc868f922017-02-15 16:01:45 -060020 ${PN}-software \
Andrew Geisslera94faf42017-05-08 15:58:01 -050021 ${PN}-host-check-mgmt \
Jayanth Othayoth9963d172017-05-08 09:25:05 -050022 ${PN}-debug-collector \
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -050023 ${PN}-settings \
Ratan Guptab6de45c2017-07-06 21:09:14 +053024 ${PN}-network \
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +053025 ${PN}-user-mgmt \
Brad Bishop93fb5352015-09-09 03:59:20 +000026 "
27
Brad Bishop46631702017-03-01 16:16:06 -050028SUMMARY_${PN}-bmc-state-mgmt = "BMC state management"
29RDEPENDS_${PN}-bmc-state-mgmt = " \
30 ${VIRTUAL-RUNTIME_obmc-bmc-state-manager} \
31 "
32
33SUMMARY_${PN}-chassis-state-mgmt = "Chassis state management"
34RDEPENDS_${PN}-chassis-state-mgmt = " \
35 ${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \
36 "
37
Andrew Geisslera94faf42017-05-08 15:58:01 -050038SUMMARY_${PN}-host-check-mgmt = "Host state check on bmc reset"
39RDEPENDS_${PN}-host-check-mgmt = " \
40 ${VIRTUAL-RUNTIME_obmc-host-check} \
41 "
42
Brad Bishop6165ec32016-09-06 22:44:21 -040043SUMMARY_${PN}-extras = "Extra features"
44RDEPENDS_${PN}-extras = " \
Brad Bishop667938f2017-01-12 21:44:51 -050045 phosphor-rest \
Brad Bishopf1cc41b2017-05-31 14:08:33 -040046 phosphor-dbus-monitor \
Brad Bishop70436da2015-09-16 14:49:27 -040047 "
48
Brad Bishop6165ec32016-09-06 22:44:21 -040049SUMMARY_${PN}-extrasdev = "Development features"
50RDEPENDS_${PN}-extrasdev = " \
Adriana Kobylakeaa56c92016-06-16 14:46:06 -050051 rest-dbus \
52 "
Brad Bishop45f8b572017-02-01 21:04:14 -050053
Adriana Kobylak0bce5322017-11-09 10:39:02 -060054SUMMARY_${PN}-extrasdevtools = "Development tools"
55RDEPENDS_${PN}-extrasdevtools = " \
56 "
57
Brad Bishop11909e02017-05-01 11:54:34 -040058# Use the fan control package group for applications
59# implementing fan control or system fan policy only.
60# Applications that create inventory or sensors should
61# be added those respective package groups instead.
62SUMMARY_${PN}-fan-control = "Fan control"
63RDEPENDS_${PN}-fan-control = " \
Matt Spinlerbd9fdd92017-04-19 08:23:50 -050064 ${VIRTUAL-RUNTIME_obmc-fan-control} \
Matt Spinler39652c82017-05-01 14:29:20 -050065 phosphor-fan-monitor \
Brad Bishop11909e02017-05-01 11:54:34 -040066 "
67
Brad Bishop46631702017-03-01 16:16:06 -050068SUMMARY_${PN}-host-state-mgmt = "Host state management"
69RDEPENDS_${PN}-host-state-mgmt = " \
70 ${VIRTUAL-RUNTIME_obmc-host-state-manager} \
Michael Tritz1f792e02017-03-31 12:04:32 -050071 ${VIRTUAL-RUNTIME_obmc-discover-system-state} \
Brad Bishop46631702017-03-01 16:16:06 -050072 "
73
Brad Bishop45f8b572017-02-01 21:04:14 -050074SUMMARY_${PN}-inventory = "Inventory applications"
75RDEPENDS_${PN}-inventory = " \
76 ${VIRTUAL-RUNTIME_obmc-inventory-manager} \
Matthew Barth91460422017-02-24 13:14:43 -060077 ${VIRTUAL-RUNTIME_obmc-fan-presence} \
Brad Bishop45f8b572017-02-01 21:04:14 -050078 "
79
80SUMMARY_${PN}-leds = "LED applications"
81RDEPENDS_${PN}-leds = " \
Brad Bishopc1d30c52017-02-27 11:59:49 -050082 ${VIRTUAL-RUNTIME_obmc-leds-manager} \
83 ${VIRTUAL-RUNTIME_obmc-leds-sysfs} \
Dhruvaraj Subhashchandrane1266ad2017-04-27 05:29:56 -050084 ${VIRTUAL-RUNTIME_obmc-led-monitor} \
Brad Bishop45f8b572017-02-01 21:04:14 -050085 "
86
87SUMMARY_${PN}-sensors = "Sensor applications"
88RDEPENDS_${PN}-sensors = " \
89 ${VIRTUAL-RUNTIME_obmc-sensors-hwmon} \
90 "
Gunnar Millsc868f922017-02-15 16:01:45 -060091
92SUMMARY_${PN}-software = "Software applications"
93RDEPENDS_${PN}-software = " \
Deepak Kodihalli60d1de52017-04-13 23:23:42 -050094 ${VIRTUAL-RUNTIME_obmc-bmc-download-mgr} \
Gunnar Mills30131f72017-05-15 15:40:58 -050095 ${VIRTUAL-RUNTIME_obmc-bmc-updater} \
Andrew Geissler1f957522018-02-09 12:50:57 -080096 ${VIRTUAL-RUNTIME_obmc-bmc-version} \
Gunnar Millsc868f922017-02-15 16:01:45 -060097 "
Andrew Geissler1f957522018-02-09 12:50:57 -080098# Determine if the non-UBI flash packages are required
99RDEPENDS_${PN}-software += " \
100 ${@mf_enabled(d, 'obmc-ubi-fs', \
101 '', \
102 'obmc-flash-bmc obmc-mgr-download')} \
103 "
104
Jayanth Othayoth9963d172017-05-08 09:25:05 -0500105SUMMARY_${PN}-debug-collector = "BMC debug collector"
106RDEPENDS_${PN}-debug-collector = " \
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -0500107 ${VIRTUAL-RUNTIME_obmc-dump-manager} \
108 ${VIRTUAL-RUNTIME_obmc-dump-monitor} \
Jayanth Othayothd2592492017-07-29 22:28:44 -0500109 phosphor-debug-collector-dreport \
Marri Devender Rao33603922017-10-11 02:22:46 -0500110 phosphor-debug-collector-scripts \
Vishwanatha Subbanna14609cb2017-05-12 23:31:55 +0530111 "
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -0500112
113SUMMARY_${PN}-settings = "Settings applications"
114RDEPENDS_${PN}-settings = " \
115 ${VIRTUAL-RUNTIME_obmc-settings-mgr} \
116 "
Ratan Guptab6de45c2017-07-06 21:09:14 +0530117
118SUMMARY_${PN}-network = "BMC Network Manager"
119RDEPENDS_${PN}-network = " \
120 ${VIRTUAL-RUNTIME_obmc-network-manager} \
121 "
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +0530122
123SUMMARY_${PN}-user-mgmt = "User management applications"
124RDEPENDS_${PN}-user-mgmt = " \
125 ${VIRTUAL-RUNTIME_obmc-user-mgmt} \
126 "