blob: f402a265dfca8713633359613293665086991997 [file] [log] [blame]
Patrick Venture028d2402018-03-09 15:37:45 -08001HOMEPAGE = "github.com/openbmc/phosphor-pid-control"
2
3LICENSE = "Apache-2.0"
James Feistbca8c432018-08-02 14:23:38 -07004LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Patrick Venture028d2402018-03-09 15:37:45 -08005
6SUMMARY = "Phosphor PID Fan Control"
7DESCRIPTION = "Fan Control"
8PR = "r1"
9
10SRC_URI = "git://github.com/openbmc/phosphor-pid-control"
Andrew Geissler1fce8a82018-09-21 01:30:17 +000011SRCREV = "07c3a80e092705e22158b37825c628df5f59dbf7"
Patrick Venture028d2402018-03-09 15:37:45 -080012S = "${WORKDIR}/git"
13
14inherit autotools pkgconfig
15inherit pythonnative
16
17inherit phosphor-pid-control
18inherit obmc-phosphor-ipmiprovider-symlink
19
20# Each platform will need a service file that starts
21# at an appropriate time per system. For instance, if
22# your system relies on passive dbus for fans or other
23# sensors then it may be prudent to wait for all of them.
24
25DEPENDS += "autoconf-archive-native"
26DEPENDS += "python-pyyaml-native"
27DEPENDS += "python-mako-native"
28DEPENDS += "sdbusplus"
29DEPENDS += "phosphor-logging"
30DEPENDS += "libevdev"
31DEPENDS += "libconfig"
32
33# We depend on someone providing their system's configuration.
34DEPENDS += "virtual/phosphor-fans-sensor-inventory"
35# We depend on this to be built first so we can build our providers.
36DEPENDS += "phosphor-ipmi-host"
37
38RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
39
40FILES_${PN} = "${sbindir}/swampd ${sbindir}/setsensor"
41
Patrick Venture13a1e6b2018-07-27 07:27:01 -070042# The following installs the OEM IPMI handler for the fan controls.
43FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
44FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
45FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
46FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Patrick Venture028d2402018-03-09 15:37:45 -080047
48EXTRA_OECONF = "SENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/sensor-list.yaml \
49 PID_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/pid-list.yaml \
50 ZONE_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/zone-info.yaml"
51
Patrick Venture13a1e6b2018-07-27 07:27:01 -070052HOSTIPMI_PROVIDER_LIBRARY += "libmanualcmds.so"