blob: b8cb9339a9ea244616442b0c8ce1422d7168b5e5 [file] [log] [blame]
Vijay Khemka2b028422019-10-30 10:31:48 -07001SUMMARY = "Chassis Power Control service for Intel based platforms"
2DESCRIPTION = "Chassis Power Control service for Intel based platforms"
3
4SRC_URI = "git://github.com/openbmc/x86-power-control.git;protocol=ssh"
Andrew Geissler2f59ab62019-10-30 18:41:29 +00005SRCREV = "6c2ad3652601ad9e5dc96c15b3cb1d3f2aab2532"
Vijay Khemka2b028422019-10-30 10:31:48 -07006
7PV = "1.0+git${SRCPV}"
8
9S = "${WORKDIR}/git"
10
11LICENSE = "Apache-2.0"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
13
14inherit cmake systemd
15
16SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Chassis.Control.Power.service"
17
18DEPENDS += " \
19 boost \
20 i2c-tools \
21 libgpiod \
22 sdbusplus \
23 phosphor-logging \
24 "