Deepak Kodihalli | 3e3c88c | 2017-05-17 06:42:51 -0500 | [diff] [blame] | 1 | SUMMARY = "Phosphor Settings Manager" |
| 2 | DESCRIPTION = "Phosphor Settings Manager is an application that creates \ |
| 3 | d-bus objects to represent various user settings." |
| 4 | PR = "r1" |
| 5 | |
| 6 | inherit autotools |
| 7 | inherit obmc-phosphor-dbus-service |
| 8 | inherit pythonnative |
| 9 | inherit phosphor-settings-manager |
| 10 | |
| 11 | require phosphor-settings-manager.inc |
| 12 | |
| 13 | DBUS_SERVICE_${PN} = "xyz.openbmc_project.Settings.service" |
| 14 | |
| 15 | DEPENDS += "python-pyyaml-native" |
| 16 | DEPENDS += "python-mako-native" |
| 17 | DEPENDS += "autoconf-archive-native" |
| 18 | DEPENDS += "virtual/phosphor-settings-defaults" |
| 19 | DEPENDS += "sdbusplus sdbusplus-native" |
| 20 | DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native" |
Deepak Kodihalli | 36006e7 | 2017-06-24 12:56:18 -0500 | [diff] [blame] | 21 | DEPENDS += "cereal" |
Deepak Kodihalli | 3e3c88c | 2017-05-17 06:42:51 -0500 | [diff] [blame] | 22 | |
| 23 | RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces" |
| 24 | |
| 25 | S = "${WORKDIR}/git" |
| 26 | |
| 27 | EXTRA_OECONF = " \ |
| 28 | SETTINGS_YAML=${STAGING_DIR_NATIVE}${settings_datadir}/defaults.yaml \ |
| 29 | " |