blob: f7c039459d5979b67ba8eb8a65e4a061c5b9b69b [file] [log] [blame]
Chris Austen213cd2a2015-10-24 19:34:11 -05001SUMMARY = "Phosphor OpenBMC OEM Commands for OpenPOWER systems"
2DESCRIPTION = "Phosphor OpenBMC IPMI OEM commands for OpenPOWER based systems"
3HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-oem"
4PR = "r1"
5
6RRECOMMENDS_${PN} = "virtual/obmc-phosphor-host-ipmi-hw"
7
8inherit obmc-phosphor-license
9
10DEPENDS += "systemd \
11 host-ipmid \
12 "
Chris Austen254cb562016-01-23 18:00:11 -060013TARGET_CFLAGS += "-fpic"
Chris Austen213cd2a2015-10-24 19:34:11 -050014
15
16RDEPENDS_${PN} += "libsystemd"
17
18
19
20SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-oem"
21
Chris Austena77b0bb2015-11-11 23:07:50 -060022SRCREV = "b7df30ea8ad991c2d811e77ed4dee1beaa766883"
Chris Austen213cd2a2015-10-24 19:34:11 -050023
24FILES_${PN} += "${libdir}/host-ipmid/*.so"
25FILES_${PN}-dbg += "${libdir}/host-ipmid/.debug"
26
27S = "${WORKDIR}/git"
28
29do_install() {
30 install -m 0755 -d ${D}${libdir}/host-ipmid
31 install -m 0755 ${S}/*.so ${D}${libdir}/host-ipmid/
32}