blob: 6a1c373af92922e2e8aa7c08011f418e0fbb12d8 [file] [log] [blame]
Brad Bishop86ee1cf2016-06-27 14:53:52 -04001SUMMARY = "OpenBMC hwmon poller"
2DESCRIPTION = "OpenBMC hwmon poller."
3PR = "r1"
4
5inherit skeleton-python
Brad Bishop0fe80462016-08-17 20:27:37 -04006inherit obmc-phosphor-systemd
Brad Bishop86ee1cf2016-06-27 14:53:52 -04007
8VIRTUAL-RUNTIME_skeleton_workbook ?= ""
9
10RDEPENDS_${PN} += "\
11 python-dbus \
12 python-json \
13 python-shell \
14 python-pygobject \
Patrick Williamsfee25822017-03-03 12:52:30 -060015 pyphosphor \
Brad Bishop1b4e4472016-08-29 21:47:04 -040016 pyphosphor-dbus \
Brad Bishop86ee1cf2016-06-27 14:53:52 -040017 ${VIRTUAL-RUNTIME_skeleton_workbook} \
18 "
19
20SKELETON_DIR = "pyhwmon"
Brad Bishop0fe80462016-08-17 20:27:37 -040021TMPL = "mapper-wait@.service"
22TGT = "obmc-fans-ready.target"
23INSTFMT = "mapper-wait@-org-openbmc-sensors-speed-fan{0}.service"
24FMT = "../${TMPL}:${TGT}.wants/${INSTFMT}"
25SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_FAN_INSTANCES')}"