blob: 72d847df8db6661cc241ade3d5ff3e3c7a6c2d03 [file] [log] [blame]
Chris Austenf7cefb12015-11-01 22:27:34 -06001SUMMARY = "Phosphor OpenBMC WriteFRU for OpenPOWER systems"
2DESCRIPTION = "Phosphor OpenBMC WriteFRU for OpenPOWER based systems"
3HOMEPAGE = "https://github.com/openbmc/ipmi-fru-parser"
4PR = "r1"
5
6RRECOMMENDS_${PN} = "virtual/obmc-phosphor-host-ipmi-hw"
7
8inherit obmc-phosphor-license
9
10DEPENDS += "systemd \
11 host-ipmid \
12 "
13
14
15RDEPENDS_${PN} += "libsystemd"
16
17TARGET_CFLAGS += "-std=gnu++14"
18
19SRC_URI += "git://github.com/openbmc/ipmi-fru-parser"
20
Chris Austen2878d962016-01-13 15:28:59 -060021SRCREV = "63696f4b23c9fd0a84ce539a6414ada406aaf229"
Chris Austenf7cefb12015-11-01 22:27:34 -060022
23FILES_${PN} += "${libdir}/host-ipmid/*.so"
24FILES_${PN}-dbg += "${libdir}/host-ipmid/.debug"
25
26S = "${WORKDIR}/git"
27
Chris Austen652fee82015-11-24 22:04:53 -060028do_install() {
29 oe_runmake install DESTDIR=${D} LIBDIR=${libdir} BINDIR=${sbindir}
Chris Austenf7cefb12015-11-01 22:27:34 -060030}
Chris Austen652fee82015-11-24 22:04:53 -060031
32
33# install -m 0755 -d ${D}${libdir}/host-ipmid
Chris Austen2878d962016-01-13 15:28:59 -060034# install -m 0755 ${S}/*.so ${D}${libdir}/host-ipmid/