blob: 6e0ad9719224edf9481084a0fbfea7622f054df6 [file] [log] [blame]
Brad Bishop86ee1cf2016-06-27 14:53:52 -04001SUMMARY = "OpenBMC PCIE slot detection utility"
2DESCRIPTION = "OpenBMC PCIE slot detection utility."
3PR = "r1"
4
5inherit skeleton-gdbus
Brad Bishop0fe80462016-08-17 20:27:37 -04006inherit obmc-phosphor-systemd
Saqib Khanc896e752017-11-13 10:47:54 -06007inherit pkgconfig
Brad Bishop86ee1cf2016-06-27 14:53:52 -04008
9SKELETON_DIR = "pciedetect"
Brad Bishop0fe80462016-08-17 20:27:37 -040010
11TMPL = "pcie-slot-detect@.service"
Andrew Geissler510ae372018-03-27 13:56:26 -070012TGTFMT = "obmc-host-startmin@{0}.target"
Brad Bishop0fe80462016-08-17 20:27:37 -040013INSTFMT = "pcie-slot-detect@{0}.service"
14FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
15
16SYSTEMD_SERVICE_${PN} += "pcie-slot-detect@.service"
17SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"