blob: 6b5761b5e7d324db2dcce36f6f8f458313a5ff19 [file] [log] [blame]
Brad Bishop86ee1cf2016-06-27 14:53:52 -04001SUMMARY = "OpenBMC PCIE slot detection utility"
2DESCRIPTION = "OpenBMC PCIE slot detection utility."
3PR = "r1"
4
5inherit skeleton-gdbus
Brad Bishop0fe80462016-08-17 20:27:37 -04006inherit obmc-phosphor-systemd
Saqib Khanc896e752017-11-13 10:47:54 -06007inherit pkgconfig
Brad Bishop86ee1cf2016-06-27 14:53:52 -04008
9SKELETON_DIR = "pciedetect"
Brad Bishop0fe80462016-08-17 20:27:37 -040010
11TMPL = "pcie-slot-detect@.service"
Josh D. Kinga283e072017-04-06 15:56:37 -050012TGTFMT = "obmc-host-start@{0}.target"
Brad Bishop0fe80462016-08-17 20:27:37 -040013INSTFMT = "pcie-slot-detect@{0}.service"
14FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
15
16SYSTEMD_SERVICE_${PN} += "pcie-slot-detect@.service"
17SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"