Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC WriteFRU for OpenPOWER systems" |
| 2 | DESCRIPTION = "Phosphor OpenBMC WriteFRU for OpenPOWER based systems" |
| 3 | HOMEPAGE = "https://github.com/openbmc/ipmi-fru-parser" |
| 4 | PR = "r1" |
| 5 | |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 6 | inherit obmc-phosphor-license |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 7 | inherit obmc-phosphor-systemd |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 8 | |
Brad Bishop | dd2e4fa | 2016-06-13 12:53:41 -0400 | [diff] [blame] | 9 | DEPENDS += " \ |
| 10 | systemd \ |
| 11 | host-ipmid \ |
| 12 | " |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 13 | |
| 14 | RDEPENDS_${PN} += "libsystemd" |
| 15 | |
Patrick Williams | 805d4db | 2016-08-30 15:17:16 -0500 | [diff] [blame] | 16 | TARGET_CXXFLAGS += " -fpic -std=gnu++14" |
Patrick Williams | 8592c8c | 2016-08-30 12:30:23 -0500 | [diff] [blame] | 17 | TARGET_CFLAGS += " -fpic" |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 18 | SYSTEMD_SERVICE_${PN} += "obmc-read-eeprom@.service" |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 19 | |
| 20 | SRC_URI += "git://github.com/openbmc/ipmi-fru-parser" |
| 21 | |
Patrick Williams | 90f35fd | 2016-10-19 22:20:03 -0500 | [diff] [blame] | 22 | SRCREV = "155c34fbb61071f5b51240c4a50b49391e0877c1" |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 23 | |
Brad Bishop | 431d598 | 2016-06-13 15:39:56 -0400 | [diff] [blame] | 24 | FILES_SOLIBSDEV += "${libdir}/host-ipmid/lib*${SOLIBSDEV}" |
| 25 | FILES_${PN} += "${libdir}/host-ipmid/lib*${SOLIBS}" |
| 26 | FILES_${PN}-dbg += "${libdir}/host-ipmid/.debug/lib*${SOLIBS}" |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 27 | |
| 28 | S = "${WORKDIR}/git" |
| 29 | |
Chris Austen | 652fee8 | 2015-11-24 22:04:53 -0600 | [diff] [blame] | 30 | do_install() { |
Brad Bishop | dd2e4fa | 2016-06-13 12:53:41 -0400 | [diff] [blame] | 31 | oe_runmake install DESTDIR=${D} LIBDIR=${libdir} BINDIR=${sbindir} |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 32 | } |