Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC WriteFRU for OpenPOWER systems" |
| 2 | DESCRIPTION = "Phosphor OpenBMC WriteFRU for OpenPOWER based systems" |
| 3 | HOMEPAGE = "https://github.com/openbmc/ipmi-fru-parser" |
| 4 | PR = "r1" |
| 5 | |
| 6 | RRECOMMENDS_${PN} = "virtual/obmc-phosphor-host-ipmi-hw" |
| 7 | |
| 8 | inherit obmc-phosphor-license |
| 9 | |
Brad Bishop | dd2e4fa | 2016-06-13 12:53:41 -0400 | [diff] [blame] | 10 | DEPENDS += " \ |
| 11 | systemd \ |
| 12 | host-ipmid \ |
| 13 | " |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 14 | |
| 15 | RDEPENDS_${PN} += "libsystemd" |
| 16 | |
Chris Austen | 254cb56 | 2016-01-23 18:00:11 -0600 | [diff] [blame] | 17 | TARGET_CFLAGS += " -fpic -std=gnu++14" |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 18 | |
| 19 | SRC_URI += "git://github.com/openbmc/ipmi-fru-parser" |
| 20 | |
Adriana Kobylak | be731de | 2016-06-18 07:52:44 -0500 | [diff] [blame] | 21 | SRCREV = "a26ed7375261ebcfffa68cf478bcb8f2204c6c92" |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 22 | |
Brad Bishop | 431d598 | 2016-06-13 15:39:56 -0400 | [diff] [blame] | 23 | FILES_SOLIBSDEV += "${libdir}/host-ipmid/lib*${SOLIBSDEV}" |
| 24 | FILES_${PN} += "${libdir}/host-ipmid/lib*${SOLIBS}" |
| 25 | FILES_${PN}-dbg += "${libdir}/host-ipmid/.debug/lib*${SOLIBS}" |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 26 | |
| 27 | S = "${WORKDIR}/git" |
| 28 | |
Chris Austen | 652fee8 | 2015-11-24 22:04:53 -0600 | [diff] [blame] | 29 | do_install() { |
Brad Bishop | dd2e4fa | 2016-06-13 12:53:41 -0400 | [diff] [blame] | 30 | oe_runmake install DESTDIR=${D} LIBDIR=${libdir} BINDIR=${sbindir} |
Chris Austen | f7cefb1 | 2015-11-01 22:27:34 -0600 | [diff] [blame] | 31 | } |