blob: 0fc872dc1712db118ace1919a95ccd447cf1dcc0 [file] [log] [blame]
Xo Wang0d917d82016-10-24 18:44:49 -07001DESCRIPTION = "Command line tools for hardware device registers"
Patrick Venture3896ac72017-10-05 15:11:30 -07002HOMEPAGE = "https://github.com/jonmayergoogle/iotools"
Xo Wang0d917d82016-10-24 18:44:49 -07003LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
Patrick Venture3896ac72017-10-05 15:11:30 -07005SRCREV = "223a7be0885dd3d0dba910d55d06745bdfd846d8"
6SRC_URI = "git://git@github.com/jonmayergoogle/iotools.git;protocol=https"
Xo Wang0d917d82016-10-24 18:44:49 -07007PV = "v1.6+git${SRCPV}"
8
9S = "${WORKDIR}/git"
10FILES_${PN} = "${sbindir}"
11
12do_compile() {
13 # CC is overridden in the Makefile, so override it harder in the invocation
14 oe_runmake CC="${CC}" DEBUG="${DEBUG_BUILD-0}" STATIC=0
15}
16
17# The "install" make target runs the binary to create links for subcommands.
18# The links are excessive and this doesn't work for cross compiling.
19do_install() {
20 install -d ${D}${sbindir}
21 install -m 0755 iotools ${D}${sbindir}
22}