blob: a500bf34ff68a2fe70a995a25fdba8578b505851 [file] [log] [blame]
Brad Bishop667938f2017-01-12 21:44:51 -05001SUMMARY = "OpenBMC - Applications"
Brad Bishop93fb5352015-09-09 03:59:20 +00002PR = "r1"
3
4inherit packagegroup
5inherit obmc-phosphor-utils
6inherit obmc-phosphor-license
7
Brad Bishop93fb5352015-09-09 03:59:20 +00008PROVIDES = "${PACKAGES}"
9PACKAGES = " \
Brad Bishop46631702017-03-01 16:16:06 -050010 ${PN}-bmc-state-mgmt \
11 ${PN}-chassis-state-mgmt \
Brad Bishop6165ec32016-09-06 22:44:21 -040012 ${PN}-extras \
13 ${PN}-extrasdev \
Brad Bishop11909e02017-05-01 11:54:34 -040014 ${PN}-fan-control \
Brad Bishop46631702017-03-01 16:16:06 -050015 ${PN}-host-state-mgmt \
Brad Bishop45f8b572017-02-01 21:04:14 -050016 ${PN}-inventory \
17 ${PN}-leds \
18 ${PN}-sensors \
Gunnar Millsc868f922017-02-15 16:01:45 -060019 ${PN}-software \
Andrew Geisslera94faf42017-05-08 15:58:01 -050020 ${PN}-host-check-mgmt \
Jayanth Othayoth9963d172017-05-08 09:25:05 -050021 ${PN}-debug-collector \
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -050022 ${PN}-settings \
Brad Bishop93fb5352015-09-09 03:59:20 +000023 "
24
Brad Bishop46631702017-03-01 16:16:06 -050025SUMMARY_${PN}-bmc-state-mgmt = "BMC state management"
26RDEPENDS_${PN}-bmc-state-mgmt = " \
27 ${VIRTUAL-RUNTIME_obmc-bmc-state-manager} \
28 "
29
30SUMMARY_${PN}-chassis-state-mgmt = "Chassis state management"
31RDEPENDS_${PN}-chassis-state-mgmt = " \
32 ${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \
33 "
34
Andrew Geisslera94faf42017-05-08 15:58:01 -050035SUMMARY_${PN}-host-check-mgmt = "Host state check on bmc reset"
36RDEPENDS_${PN}-host-check-mgmt = " \
37 ${VIRTUAL-RUNTIME_obmc-host-check} \
38 "
39
Brad Bishop6165ec32016-09-06 22:44:21 -040040SUMMARY_${PN}-extras = "Extra features"
41RDEPENDS_${PN}-extras = " \
Brad Bishop667938f2017-01-12 21:44:51 -050042 phosphor-rest \
Brad Bishop70436da2015-09-16 14:49:27 -040043 "
44
Brad Bishop6165ec32016-09-06 22:44:21 -040045SUMMARY_${PN}-extrasdev = "Development features"
46RDEPENDS_${PN}-extrasdev = " \
Adriana Kobylakeaa56c92016-06-16 14:46:06 -050047 rest-dbus \
48 "
Brad Bishop45f8b572017-02-01 21:04:14 -050049
Brad Bishop11909e02017-05-01 11:54:34 -040050# Use the fan control package group for applications
51# implementing fan control or system fan policy only.
52# Applications that create inventory or sensors should
53# be added those respective package groups instead.
54SUMMARY_${PN}-fan-control = "Fan control"
55RDEPENDS_${PN}-fan-control = " \
Matt Spinlerbd9fdd92017-04-19 08:23:50 -050056 ${VIRTUAL-RUNTIME_obmc-fan-control} \
Matt Spinler39652c82017-05-01 14:29:20 -050057 phosphor-fan-monitor \
Brad Bishop11909e02017-05-01 11:54:34 -040058 "
59
Brad Bishop46631702017-03-01 16:16:06 -050060SUMMARY_${PN}-host-state-mgmt = "Host state management"
61RDEPENDS_${PN}-host-state-mgmt = " \
62 ${VIRTUAL-RUNTIME_obmc-host-state-manager} \
Michael Tritz1f792e02017-03-31 12:04:32 -050063 ${VIRTUAL-RUNTIME_obmc-discover-system-state} \
Brad Bishop46631702017-03-01 16:16:06 -050064 "
65
Brad Bishop45f8b572017-02-01 21:04:14 -050066SUMMARY_${PN}-inventory = "Inventory applications"
67RDEPENDS_${PN}-inventory = " \
68 ${VIRTUAL-RUNTIME_obmc-inventory-manager} \
Matthew Barth91460422017-02-24 13:14:43 -060069 ${VIRTUAL-RUNTIME_obmc-fan-presence} \
Brad Bishop45f8b572017-02-01 21:04:14 -050070 "
71
72SUMMARY_${PN}-leds = "LED applications"
73RDEPENDS_${PN}-leds = " \
Brad Bishopc1d30c52017-02-27 11:59:49 -050074 ${VIRTUAL-RUNTIME_obmc-leds-manager} \
75 ${VIRTUAL-RUNTIME_obmc-leds-sysfs} \
Dhruvaraj Subhashchandrane1266ad2017-04-27 05:29:56 -050076 ${VIRTUAL-RUNTIME_obmc-led-monitor} \
Brad Bishop45f8b572017-02-01 21:04:14 -050077 "
78
79SUMMARY_${PN}-sensors = "Sensor applications"
80RDEPENDS_${PN}-sensors = " \
81 ${VIRTUAL-RUNTIME_obmc-sensors-hwmon} \
82 "
Gunnar Millsc868f922017-02-15 16:01:45 -060083
84SUMMARY_${PN}-software = "Software applications"
85RDEPENDS_${PN}-software = " \
86 ${VIRTUAL-RUNTIME_obmc-bmc-code-mgr} \
Deepak Kodihalli60d1de52017-04-13 23:23:42 -050087 ${VIRTUAL-RUNTIME_obmc-bmc-download-mgr} \
Gunnar Mills30131f72017-05-15 15:40:58 -050088 ${VIRTUAL-RUNTIME_obmc-bmc-updater} \
Gunnar Millsc868f922017-02-15 16:01:45 -060089 "
Jayanth Othayoth9963d172017-05-08 09:25:05 -050090SUMMARY_${PN}-debug-collector = "BMC debug collector"
91RDEPENDS_${PN}-debug-collector = " \
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -050092 ${VIRTUAL-RUNTIME_obmc-dump-manager} \
93 ${VIRTUAL-RUNTIME_obmc-dump-monitor} \
Vishwanatha Subbanna14609cb2017-05-12 23:31:55 +053094 "
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -050095
96SUMMARY_${PN}-settings = "Settings applications"
97RDEPENDS_${PN}-settings = " \
98 ${VIRTUAL-RUNTIME_obmc-settings-mgr} \
99 "