Brad Bishop | b0c3b27 | 2017-01-11 11:12:32 -0500 | [diff] [blame] | 1 | SUMMARY = "OpenBMC hwmon poller" |
| 2 | DESCRIPTION = "OpenBMC hwmon poller." |
| 3 | PR = "r1" |
| 4 | |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc" |
| 7 | |
Brad Bishop | 030da25 | 2017-01-11 15:30:07 -0500 | [diff] [blame] | 8 | inherit autotools pkgconfig obmc-phosphor-systemd |
| 9 | |
Brad Bishop | 1d34ddd | 2017-08-01 21:33:30 -0400 | [diff] [blame] | 10 | PACKAGE_BEFORE_PN = "max31785-msl" |
| 11 | SYSTEMD_PACKAGES = "${PN} max31785-msl" |
| 12 | |
Brad Bishop | 030da25 | 2017-01-11 15:30:07 -0500 | [diff] [blame] | 13 | SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Hwmon@.service" |
Brad Bishop | 1d34ddd | 2017-08-01 21:33:30 -0400 | [diff] [blame] | 14 | SYSTEMD_SERVICE_max31785-msl = "phosphor-max31785-msl@.service" |
Brad Bishop | b0c3b27 | 2017-01-11 11:12:32 -0500 | [diff] [blame] | 15 | |
| 16 | DEPENDS += "autoconf-archive-native" |
Brad Bishop | f4393bf | 2017-02-20 14:36:31 -0500 | [diff] [blame] | 17 | DEPENDS += " \ |
| 18 | sdbusplus \ |
| 19 | phosphor-dbus-interfaces \ |
| 20 | phosphor-logging \ |
| 21 | " |
| 22 | |
Brad Bishop | b0c3b27 | 2017-01-11 11:12:32 -0500 | [diff] [blame] | 23 | |
| 24 | RDEPENDS_${PN} += "\ |
Brad Bishop | f4393bf | 2017-02-20 14:36:31 -0500 | [diff] [blame] | 25 | sdbusplus \ |
| 26 | phosphor-dbus-interfaces \ |
| 27 | phosphor-logging \ |
Joel Stanley | 7b29e20 | 2017-09-05 17:44:33 +1000 | [diff] [blame] | 28 | bash \ |
Brad Bishop | b0c3b27 | 2017-01-11 11:12:32 -0500 | [diff] [blame] | 29 | " |
| 30 | |
Brad Bishop | fe7871c | 2017-02-22 20:50:13 -0500 | [diff] [blame] | 31 | RRECOMMENDS_${PN} += "${VIRTUAL-RUNTIME_phosphor-hwmon-config}" |
| 32 | |
Brad Bishop | 1d34ddd | 2017-08-01 21:33:30 -0400 | [diff] [blame] | 33 | FILES_max31785-msl = "${bindir}/max31785-msl" |
| 34 | RDEPENDS_max31785-msl = "${VIRTUAL-RUNTIME_base-utils} i2c-tools" |
| 35 | |
Brad Bishop | b0c3b27 | 2017-01-11 11:12:32 -0500 | [diff] [blame] | 36 | SRC_URI += "git://github.com/openbmc/phosphor-hwmon" |
Brad Bishop | 030da25 | 2017-01-11 15:30:07 -0500 | [diff] [blame] | 37 | SRC_URI += "file://70-hwmon.rules" |
Brandon Wyman | 675ce0b | 2017-06-21 16:32:56 -0500 | [diff] [blame] | 38 | SRC_URI += "file://70-iio.rules" |
Joel Stanley | 7b29e20 | 2017-09-05 17:44:33 +1000 | [diff] [blame] | 39 | SRC_URI += "file://start_hwmon.sh" |
Brad Bishop | b0c3b27 | 2017-01-11 11:12:32 -0500 | [diff] [blame] | 40 | |
Andrew Geissler | ce63ce3 | 2018-09-05 19:00:24 +0000 | [diff] [blame] | 41 | SRCREV = "cc86915b988098032d56a233f4f5de9f3c91f138" |
Brad Bishop | b0c3b27 | 2017-01-11 11:12:32 -0500 | [diff] [blame] | 42 | |
| 43 | S = "${WORKDIR}/git" |
Brad Bishop | 030da25 | 2017-01-11 15:30:07 -0500 | [diff] [blame] | 44 | |
| 45 | do_install_append() { |
| 46 | |
Brad Bishop | f5812fd | 2017-01-26 09:12:57 -0500 | [diff] [blame] | 47 | install -d ${D}/${base_libdir}/udev/rules.d/ |
| 48 | install ${WORKDIR}/70-hwmon.rules ${D}/${base_libdir}/udev/rules.d/ |
Brandon Wyman | 675ce0b | 2017-06-21 16:32:56 -0500 | [diff] [blame] | 49 | install ${WORKDIR}/70-iio.rules ${D}/${base_libdir}/udev/rules.d/ |
Joel Stanley | 7b29e20 | 2017-09-05 17:44:33 +1000 | [diff] [blame] | 50 | |
| 51 | install -d ${D}${bindir} |
| 52 | install -m 0755 ${WORKDIR}/start_hwmon.sh ${D}${bindir} |
Brad Bishop | 030da25 | 2017-01-11 15:30:07 -0500 | [diff] [blame] | 53 | } |