blob: 7ae05ce8081f145ed9f46290ea43006358b461d7 [file] [log] [blame]
Matt Spinlerb89b9e72017-04-17 16:34:24 -05001SUMMARY = "Generate fan control YAML from the MRW"
2PR = "r1"
3
4inherit native
5inherit obmc-phosphor-license
6inherit phosphor-fan
Matt Spinler3f6fcbe2017-12-14 13:31:55 -06007inherit mrw-xml
Matt Spinlerb89b9e72017-04-17 16:34:24 -05008
9DEPENDS += " \
10 mrw-native \
11 mrw-perl-tools-native \
12 "
13
14PROVIDES += "virtual/phosphor-fan-control-fan-config"
15
16S = "${WORKDIR}"
17
18do_compile() {
19 ${bindir}/perl-native/perl \
20 ${bindir}/gen_fan_zone_yaml.pl \
Matt Spinler3f6fcbe2017-12-14 13:31:55 -060021 -i ${mrw_datadir}/${MRW_XML} \
Matt Spinlerb89b9e72017-04-17 16:34:24 -050022 -o ${S}/fans.yaml
23}
24
25do_install() {
26 DEST=${D}${control_datadir}
27 install -D ${S}/fans.yaml ${DEST}/fans.yaml
28}