blob: f04d89f7d43883794c8eaa06d37a688d7503f4f8 [file] [log] [blame]
Tom Josephf2614f92017-05-08 11:49:10 +05301SUMMARY = "Inventory to Sensor config for phosphor-host-ipmi"
2PR = "r1"
3
4inherit native
5inherit obmc-phosphor-license
6inherit phosphor-ipmi-host
Matt Spinler3f6fcbe2017-12-14 13:31:55 -06007inherit mrw-xml
Tom Josephf2614f92017-05-08 11:49:10 +05308
9SRC_URI += "file://config.yaml"
10
11DEPENDS += " \
12 mrw-native \
13 mrw-perl-tools-native \
14 "
15
16PROVIDES += "virtual/phosphor-ipmi-inventory-sel"
17
18S = "${WORKDIR}"
19
20do_install() {
21 DEST=${D}${sensor_datadir}
22 install -d ${DEST}
23
24 ${bindir}/perl-native/perl \
25 ${bindir}/gen_ipmi_sel.pl \
Matt Spinler3f6fcbe2017-12-14 13:31:55 -060026 -i ${mrw_datadir}/${MRW_XML} \
Tom Josephf2614f92017-05-08 11:49:10 +053027 -m config.yaml \
28 -o ${DEST}/invsensor.yaml
29}