blob: c27937a0c51800ba593f8934ba8bdc3418983a57 [file] [log] [blame]
Chris Austen737b35f2015-10-25 00:21:04 -05001SUMMARY = "Phosphor OpenBMC Event Management"
2DESCRIPTION = "Phosphor OpenBMC event management reference implementation."
Chris Austen3fef0762015-10-30 15:59:47 -05003HOMEPAGE = "https://github.com/openbmc/phosphor-event"
Chris Austen737b35f2015-10-25 00:21:04 -05004PR = "r1"
5
6
7inherit obmc-phosphor-license
8inherit obmc-phosphor-event-mgmt
9inherit obmc-phosphor-sdbus-service
10inherit obmc-phosphor-c-daemon
11
Chris Austen737b35f2015-10-25 00:21:04 -050012
Chris Austen3fef0762015-10-30 15:59:47 -050013SRC_URI += "git://github.com/openbmc/phosphor-event"
14
15SRCREV = "0a4a39e46622a9d6d4719b14f8955866fdb51a20"
Chris Austen737b35f2015-10-25 00:21:04 -050016
17RDEPENDS_${PN} += "libsystemd"
18DEPENDS += "systemd"
19
20
21S = "${WORKDIR}/git"
22INSTALL_NAME = "event_messaged"
23
24do_install() {
25 install -m 0755 -d ${D}${sbindir}
26 install -m 0755 ${S}/${INSTALL_NAME} ${D}/${sbindir}/obmc-phosphor-eventd
27}