Brad Bishop | c642e5c | 2017-07-10 21:56:17 -0400 | [diff] [blame] | 1 | # Provides the config file for the phosphor-fan-presence application. |
| 2 | # The default config file is empty. To provide a real one, |
| 3 | # append this recipe in a layer, add: |
| 4 | # FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
| 5 | # and provide a config file. |
| 6 | |
| 7 | SUMMARY = "Config file for phosphor-fan-presence" |
| 8 | PR = "r1" |
| 9 | |
| 10 | inherit native |
| 11 | inherit phosphor-fan |
| 12 | inherit obmc-phosphor-license |
| 13 | |
| 14 | PROVIDES += "virtual/phosphor-fan-presence-config" |
| 15 | |
| 16 | SRC_URI += "file://config.yaml" |
| 17 | |
| 18 | S = "${WORKDIR}" |
| 19 | |
| 20 | do_install() { |
| 21 | install -D config.yaml ${D}${presence_datadir}/config.yaml |
| 22 | } |