Vijay Khemka | 28c1697 | 2019-12-16 17:48:02 -0800 | [diff] [blame] | 1 | SUMMARY = "Phosphor post code manager" |
| 2 | DESCRIPTION = "Phosphor post Code Manager monitors post code posted on dbus \ |
| 3 | interface /xyz/openbmc_project/state/boot/raw by snoopd daemon and save them \ |
| 4 | in a file under /var/lib for history." |
| 5 | |
| 6 | SRC_URI = "git://github.com/openbmc/phosphor-post-code-manager.git" |
Andrew Geissler | c5d5f99 | 2020-12-08 07:23:32 +0000 | [diff] [blame] | 7 | SRCREV = "fd45f78858304f67a0e80224a99cbe76eed82af0" |
Vijay Khemka | 28c1697 | 2019-12-16 17:48:02 -0800 | [diff] [blame] | 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
| 11 | PV = "1.0+git${SRCPV}" |
| 12 | |
| 13 | LICENSE = "Apache-2.0" |
| 14 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 15 | |
| 16 | inherit cmake pkgconfig systemd |
| 17 | |
Kumar Thangavel | 57042e2 | 2020-09-01 23:05:19 +0530 | [diff] [blame] | 18 | |
| 19 | def get_service(d): |
| 20 | if(d.getVar('OBMC_HOST_INSTANCES') == '0'): |
| 21 | return "xyz.openbmc_project.State.Boot.PostCode.service" |
| 22 | else: |
| 23 | return " ".join(["xyz.openbmc_project.State.Boot.PostCode@{}.service".format(x) for x in d.getVar('OBMC_HOST_INSTANCES').split()]) |
| 24 | |
| 25 | SYSTEMD_SERVICE_${PN} = "${@get_service(d)}" |
Vijay Khemka | 28c1697 | 2019-12-16 17:48:02 -0800 | [diff] [blame] | 26 | |
| 27 | DEPENDS += " \ |
| 28 | sdbusplus \ |
| 29 | phosphor-dbus-interfaces \ |
| 30 | phosphor-logging \ |
| 31 | " |
Kumar Thangavel | 57042e2 | 2020-09-01 23:05:19 +0530 | [diff] [blame] | 32 | |
| 33 | FILES_${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.State.Boot.PostCode@.service" |
| 34 | FILES_${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.State.Boot.PostCode.service" |