blob: 07c2d6762b9be998d67f5c3248ab4b02f57e9e62 [file] [log] [blame]
Brad Bishope94b9152016-08-08 20:21:44 -04001SUMMARY = "Phosphor Systemd targets"
2DESCRIPTION = "Provides well known Systemd syncronization points for OpenBMC."
3HOMEPAGE = "http://github.com/openbmc"
4PR = "r1"
5
6inherit obmc-phosphor-systemd
7inherit obmc-phosphor-license
8inherit allarch
9
Josh D. Kinga283e072017-04-06 15:56:37 -050010# Chassis power synchronization targets
Andrew Geissler997ed662017-03-05 20:36:50 -060011# - start-pre: Services to run before we start power on process
12# - start: Services to run to do the chassis power on
13# - on: Services to run once power is on
14# - stop-pre,stop,off: Same as above but applied to powering off
15# - reset-on: Services to check if chassis power is on after bmc reset
Josh D. Kinga283e072017-04-06 15:56:37 -050016CHASSIS_SYNCH_TARGETS = "start-pre start on stop-pre stop off reset-on"
Andrew Geissler997ed662017-03-05 20:36:50 -060017
Josh D. Kinga283e072017-04-06 15:56:37 -050018# Chassis action power targets
Andrew Geissler997ed662017-03-05 20:36:50 -060019# - on: Services to run to power on the chassis
20# - off: Services to run to power off the chassis
Andrew Geissler997ed662017-03-05 20:36:50 -060021# - reset: Services to check chassis power state and update chassis "on" target
Andrew Geissler4a0f3322017-07-20 10:28:34 -050022# - hard-off: Services to force an immediate power off of the chassis
23CHASSIS_ACTION_TARGETS = "poweron poweroff powerreset hard-poweroff"
Andrew Geissler997ed662017-03-05 20:36:50 -060024
25# Track all host synchronization point targets
Josh D. Kinga283e072017-04-06 15:56:37 -050026# - start-pre: Services to run before we start host boot
27# - starting: Services to run to do the host boot
28# - started: Services to run once the host is booted
29# - stop-pre,stopping,stopped: Same as above but applied to shutting down the host
30# - reset-running: Services to check if host is running after bmc reset
31HOST_SYNCH_TARGETS = "start-pre starting started stop-pre stopping stopped reset-running"
Andrew Geissler997ed662017-03-05 20:36:50 -060032
Andrew Geissler9ccc3662017-01-04 11:11:00 -060033# Track all host action targets
Josh D. King3c7a8ef2017-04-11 09:48:10 -050034# - start: Service to run to start the host
35# - stop: Services to run to shutdown the host
36# - quiesce: Target to enter on host boot failure
37# - shutdown: Tell host to shutdown, then stop system
Josh D. Kinga283e072017-04-06 15:56:37 -050038# - reset: Services to check if host is running and update host "start" target
Vishwanatha Subbanna49c4e502017-04-04 16:41:02 +053039# - crash: Target to run when host crashes. it is very much similar to
40# quiesce target but the only delta is that this target contains
41# multiple services and one of them is the quiesce target.
Vishwanatha Subbannafad09562017-06-12 14:48:29 +053042# - timeout: Target to run when host watchdog times out
43HOST_ACTION_TARGETS = "start stop quiesce reset shutdown crash timeout"
Brad Bishope94b9152016-08-08 20:21:44 -040044
Josh D. Kinga283e072017-04-06 15:56:37 -050045CHASSIS_SYNCH_FMT = "obmc-power-{0}@.target"
Andrew Geissler4a0f3322017-07-20 10:28:34 -050046CHASSIS_ACTION_FMT = "obmc-chassis-{0}@.target"
Andrew Geissler9ccc3662017-01-04 11:11:00 -060047HOST_SYNCH_FMT = "obmc-host-{0}@.target"
Josh D. Kinga283e072017-04-06 15:56:37 -050048HOST_ACTION_FMT = "obmc-host-{0}@.target"
Brad Bishope94b9152016-08-08 20:21:44 -040049
Josh D. Kinga283e072017-04-06 15:56:37 -050050CHASSIS_LINK_SYNCH_FMT = "${CHASSIS_SYNCH_FMT}:obmc-power-{0}@{1}.target"
Andrew Geissler4a0f3322017-07-20 10:28:34 -050051CHASSIS_LINK_ACTION_FMT = "${CHASSIS_ACTION_FMT}:obmc-chassis-{0}@{1}.target"
Andrew Geissler9ccc3662017-01-04 11:11:00 -060052HOST_LINK_SYNCH_FMT = "${HOST_SYNCH_FMT}:obmc-host-{0}@{1}.target"
Josh D. Kinga283e072017-04-06 15:56:37 -050053HOST_LINK_ACTION_FMT = "${HOST_ACTION_FMT}:obmc-host-{0}@{1}.target"
Matt Spinler393c9b12017-05-16 11:57:20 -050054FAN_LINK_FMT = "obmc-fan-control-ready@.target:obmc-fan-control-ready@{0}.target"
Brad Bishope94b9152016-08-08 20:21:44 -040055
Vishwanatha Subbannafad09562017-06-12 14:48:29 +053056# Targets to be executed on checkstop and watchdog timeout
57HOST_ERROR_TARGETS = "crash timeout"
58
Vishwanatha Subbanna49c4e502017-04-04 16:41:02 +053059QUIESCE_TMPL = "obmc-host-quiesce@.target"
Vishwanatha Subbannafad09562017-06-12 14:48:29 +053060CRASH_TIMEOUT_TGTFMT = "obmc-host-{0}@{1}.target"
61QUIESCE_INSTFMT = "obmc-host-quiesce@{1}.target"
62QUIESCE_FMT = "../${QUIESCE_TMPL}:${CRASH_TIMEOUT_TGTFMT}.wants/${QUIESCE_INSTFMT}"
Vishwanatha Subbanna49c4e502017-04-04 16:41:02 +053063
Brad Bishope94b9152016-08-08 20:21:44 -040064SYSTEMD_SERVICE_${PN} += " \
65 obmc-mapper.target \
Brad Bishopd969da32016-08-30 00:21:14 -040066 obmc-webserver-pre.target \
Brad Bishope94b9152016-08-08 20:21:44 -040067 obmc-fans-ready.target \
68 obmc-fan-control.target \
Matt Spinler393c9b12017-05-16 11:57:20 -050069 obmc-fan-control-ready@.target \
Matt Spinler4c2af632017-06-08 12:20:07 -050070 obmc-fan-watchdog-takeover.target \
Brad Bishope94b9152016-08-08 20:21:44 -040071 obmc-standby.target \
72 "
73
Josh D. Kinga283e072017-04-06 15:56:37 -050074SYSTEMD_SERVICE_${PN} += "${@compose_list(d, 'CHASSIS_SYNCH_FMT', 'CHASSIS_SYNCH_TARGETS')}"
75SYSTEMD_SERVICE_${PN} += "${@compose_list(d, 'CHASSIS_ACTION_FMT', 'CHASSIS_ACTION_TARGETS')}"
Andrew Geissler9ccc3662017-01-04 11:11:00 -060076SYSTEMD_SERVICE_${PN} += "${@compose_list(d, 'HOST_SYNCH_FMT', 'HOST_SYNCH_TARGETS')}"
77SYSTEMD_SERVICE_${PN} += "${@compose_list(d, 'HOST_ACTION_FMT', 'HOST_ACTION_TARGETS')}"
Brad Bishope94b9152016-08-08 20:21:44 -040078
Josh D. Kinga283e072017-04-06 15:56:37 -050079SYSTEMD_LINK_${PN} += "${@compose_list(d, 'CHASSIS_LINK_SYNCH_FMT', 'CHASSIS_SYNCH_TARGETS', 'OBMC_CHASSIS_INSTANCES')}"
80SYSTEMD_LINK_${PN} += "${@compose_list(d, 'CHASSIS_LINK_ACTION_FMT', 'CHASSIS_ACTION_TARGETS', 'OBMC_CHASSIS_INSTANCES')}"
Andrew Geissler9ccc3662017-01-04 11:11:00 -060081SYSTEMD_LINK_${PN} += "${@compose_list(d, 'HOST_LINK_SYNCH_FMT', 'HOST_SYNCH_TARGETS', 'OBMC_HOST_INSTANCES')}"
82SYSTEMD_LINK_${PN} += "${@compose_list(d, 'HOST_LINK_ACTION_FMT', 'HOST_ACTION_TARGETS', 'OBMC_HOST_INSTANCES')}"
Matt Spinler393c9b12017-05-16 11:57:20 -050083SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FAN_LINK_FMT', 'OBMC_CHASSIS_INSTANCES')}"
Vishwanatha Subbannafad09562017-06-12 14:48:29 +053084SYSTEMD_LINK_${PN} += "${@compose_list(d, 'QUIESCE_FMT', 'HOST_ERROR_TARGETS', 'OBMC_HOST_INSTANCES')}"