blob: f09f4df50b7f466629807411de6234d4ada5bef7 [file] [log] [blame]
Gunnar Mills35591d42017-01-27 13:13:24 -06001SUMMARY = "Phosphor Software Management"
2DESCRIPTION = "Phosphor Software Manager provides a set of system software \
3management daemons. It is suitable for use on a wide variety of OpenBMC \
4platforms."
5HOMEPAGE = "https://github.com/openbmc/phosphor-bmc-code-mgmt"
6PR = "r1"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9
10SOFTWARE_MGR_PACKAGES = " \
11 ${PN}-version \
12"
13PACKAGE_BEFORE_PN = "${PN}-version"
Brad Bishop4c43bb52017-03-01 15:37:17 -050014PACKAGES_remove = "${PN}"
15RDEPENDS_${PN}-dev = "${SOFTWARE_MGR_PACKAGES}"
16RDEPENDS_${PN}-staticdev = "${SOFTWARE_MGR_PACKAGES}"
17
Gunnar Mills35591d42017-01-27 13:13:24 -060018DBUS_PACKAGES = "${SOFTWARE_MGR_PACKAGES}"
19
20# Set SYSTEMD_PACKAGES to empty because we do not want ${PN} and DBUS_PACKAGES
21# handles the rest.
22SYSTEMD_PACKAGES = ""
23
24inherit autotools pkgconfig
25inherit obmc-phosphor-dbus-service
26
27DEPENDS += "autoconf-archive-native"
28DEPENDS += "sdbusplus"
29DEPENDS += "phosphor-dbus-interfaces"
30
31RDEPENDS_${PN}-version += "phosphor-dbus-interfaces sdbusplus"
32
33FILES_${PN}-version = "${sbindir}/phosphor-version-software-manager"
Gunnar Mills17ee7b12017-02-22 11:41:12 -060034DBUS_SERVICE_${PN}-version += "xyz.openbmc_project.Software.BMC.Version.service"
Gunnar Mills35591d42017-01-27 13:13:24 -060035
36SRC_URI += "git://github.com/openbmc/phosphor-bmc-code-mgmt"
37SRCREV = "af4759e828690e51035c9d11c2a6845d9bb38406"
38
39S = "${WORKDIR}/git"