Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 1 | SUMMARY = "OpenBMC python devtools" |
| 2 | DESCRIPTION = "Shortcut scripts for developers." |
| 3 | PR = "r1" |
| 4 | |
| 5 | inherit skeleton-python |
| 6 | |
| 7 | VIRTUAL-RUNTIME_skeleton_workbook ?= "" |
| 8 | |
| 9 | RDEPENDS_${PN} += "\ |
| 10 | python-dbus \ |
| 11 | python-json \ |
| 12 | python-xml \ |
| 13 | python-pygobject \ |
| 14 | ${VIRTUAL-RUNTIME_skeleton_workbook} \ |
| 15 | " |
| 16 | |
| 17 | SKELETON_DIR = "pytools" |
Andrew Jeffery | e6e3f46 | 2018-02-26 11:25:27 +1030 | [diff] [blame] | 18 | |
| 19 | do_install_append() { |
| 20 | if [ -f ${S}/obmcutil-completion.sh ] |
| 21 | then |
Brad Bishop | d1413ae | 2018-03-01 16:21:40 -0500 | [diff] [blame] | 22 | install -d ${D}${sysconfdir}/profile.d |
| 23 | install -m 0644 -D -t ${D}${sysconfdir}/profile.d ${S}/obmcutil-completion.sh |
Andrew Jeffery | e6e3f46 | 2018-02-26 11:25:27 +1030 | [diff] [blame] | 24 | fi |
| 25 | } |