blob: 6b38a537290eb50ea2a931c5804a0c9999166ed9 [file] [log] [blame]
Brad Bishop595edcf2016-11-09 20:43:11 -05001SUMMARY = "C++ bindings for systemd dbus APIs"
2DESCRIPTION = "C++ bindings for systemd dbus APIs."
3HOMEPAGE = "http://github.com/openbmc/sdbusplus"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
7
8inherit autotools pkgconfig
Patrick Williams58185302016-11-22 07:01:14 -06009inherit obmc-phosphor-python-autotools
Brad Bishop595edcf2016-11-09 20:43:11 -050010
11DEPENDS += "autoconf-archive-native"
12RDEPENDS_${PN} += " \
13 python-inflection \
14 python-mako \
15 python-pyyaml \
16 "
17
18SRC_URI += "git://github.com/openbmc/sdbusplus"
Patrick Williams25707712016-11-18 15:30:03 -060019SRCREV = "aa71a3ed5dc2d128223ff3dc5f0c04474be40803"
Brad Bishop595edcf2016-11-09 20:43:11 -050020
21PACKAGECONFIG ??= "libsdbusplus"
22PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
23
24S = "${WORKDIR}/git"
25
26PACKAGECONFIG_remove_class-native = "libsdbusplus"
27PACKAGECONFIG_remove_class-nativesdk = "libsdbusplus"
28
Brad Bishop595edcf2016-11-09 20:43:11 -050029BBCLASSEXTEND += "native nativesdk"