blob: d5b73beaef1f8a1616db36015773c103ad1eb8ae [file] [log] [blame]
Vijay Khemka28c16972019-12-16 17:48:02 -08001SUMMARY = "Phosphor post code manager"
2DESCRIPTION = "Phosphor post Code Manager monitors post code posted on dbus \
3interface /xyz/openbmc_project/state/boot/raw by snoopd daemon and save them \
4in a file under /var/lib for history."
5
6SRC_URI = "git://github.com/openbmc/phosphor-post-code-manager.git"
Matt Spinler585674d2020-03-25 08:49:34 -05007SRCREV = "993d4dd9dc583e62a84c6056edffad957d7b7b5d"
Vijay Khemka28c16972019-12-16 17:48:02 -08008
9S = "${WORKDIR}/git"
10
11PV = "1.0+git${SRCPV}"
12
13LICENSE = "Apache-2.0"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
15
16inherit cmake pkgconfig systemd
17
18SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.State.Boot.PostCode.service"
19
20DEPENDS += " \
21 sdbusplus \
22 phosphor-dbus-interfaces \
23 phosphor-logging \
24 "