blob: f49b3fcce6890b08400ceae8a6bde03c8559633c [file] [log] [blame]
Brad Bishop4ccd9f32015-10-06 00:27:43 -04001DESCRIPTION = "Linux kernel for OpenBMC"
2SECTION = "kernel"
3LICENSE = "GPLv2"
4
5KBRANCH ?= "dev"
Brad Bishop7d3e4f32015-10-30 03:11:05 -04006KCONFIG_MODE="--alldefconfig"
Brad Bishop4ccd9f32015-10-06 00:27:43 -04007
8SRC_URI = "git://github.com/openbmc/linux;protocol=git;branch=${KBRANCH}"
Brad Bishop4ccd9f32015-10-06 00:27:43 -04009
10LINUX_VERSION ?= "4.2"
Brad Bishop7d3e4f32015-10-30 03:11:05 -040011LINUX_VERSION_EXTENSION ?= "-${SRCREV}"
Brad Bishop4ccd9f32015-10-06 00:27:43 -040012
Brad Bishop8be89a12015-10-28 10:21:32 -040013SRCREV="openbmc-20151028-1"
Brad Bishop4ccd9f32015-10-06 00:27:43 -040014
15PV = "${LINUX_VERSION}+git${SRCPV}"
16
17COMPATIBLE_MACHINE_${MACHINE} = "openbmc"
18
19inherit kernel
20require recipes-kernel/linux/linux-yocto.inc