vishwabmc | 1bf499d | 2015-10-09 15:51:50 +0530 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC IPMI daemon" |
| 2 | DESCRIPTION = "Phosphor OpenBMC IPMI router and plugin libraries" |
| 3 | HOMEPAGE = "http://github.com/openbmc/phosphor-host-ipmid" |
| 4 | PR = "r1" |
| 5 | |
Brad Bishop | 7ee7146 | 2016-08-19 09:02:54 -0500 | [diff] [blame] | 6 | RRECOMMENDS_${PN} += "packagegroup-obmc-ipmid-providers-libs" |
Chris Austen | 213cd2a | 2015-10-24 19:34:11 -0500 | [diff] [blame] | 7 | |
Matthew Barth | 302592f | 2016-08-16 16:51:35 -0500 | [diff] [blame] | 8 | inherit autotools pkgconfig |
vishwabmc | 1bf499d | 2015-10-09 15:51:50 +0530 | [diff] [blame] | 9 | inherit obmc-phosphor-license |
Patrick Williams | f771406 | 2015-10-15 15:20:20 -0500 | [diff] [blame] | 10 | inherit obmc-phosphor-sdbus-service |
vishwabmc | 1bf499d | 2015-10-09 15:51:50 +0530 | [diff] [blame] | 11 | |
Brad Bishop | 1122eb0 | 2016-10-05 20:10:23 -0400 | [diff] [blame] | 12 | DEPENDS += "phosphor-mapper" |
Matthew Barth | 302592f | 2016-08-16 16:51:35 -0500 | [diff] [blame] | 13 | DEPENDS += "autoconf-archive-native" |
Brad Bishop | 1122eb0 | 2016-10-05 20:10:23 -0400 | [diff] [blame] | 14 | RDEPENDS_${PN}-dev += "phosphor-mapper-dev" |
Milton D. Miller II | 611e3ff | 2016-03-04 15:29:29 -0600 | [diff] [blame] | 15 | RDEPENDS_${PN} += "clear-once" |
Adriana Kobylak | 8f2f3b3 | 2016-01-30 10:41:48 -0600 | [diff] [blame] | 16 | RDEPENDS_${PN} += "network" |
Brad Bishop | 9a701b4 | 2016-07-26 15:52:01 -0400 | [diff] [blame] | 17 | RDEPENDS_${PN} += "libmapper" |
Vishwanatha Subbanna | 78bc542 | 2016-11-10 21:52:46 +0530 | [diff] [blame] | 18 | RDEPENDS_${PN} += "phosphor-time-manager" |
Adriana Kobylak | 79841ae | 2016-08-25 10:07:34 -0500 | [diff] [blame] | 19 | RRECOMMENDS_${PN} += "virtual-obmc-settings-mgmt" |
vishwabmc | 1bf499d | 2015-10-09 15:51:50 +0530 | [diff] [blame] | 20 | SRC_URI += "git://github.com/openbmc/phosphor-host-ipmid" |
| 21 | |
Patrick Williams | 6c78972 | 2017-01-04 11:20:03 -0600 | [diff] [blame] | 22 | SRCREV = "a640b775491bff926ac759ffd6e13ec2bcc80d26" |
Chris Austen | 213cd2a | 2015-10-24 19:34:11 -0500 | [diff] [blame] | 23 | |
vishwabmc | 1bf499d | 2015-10-09 15:51:50 +0530 | [diff] [blame] | 24 | S = "${WORKDIR}/git" |
| 25 | |
Matthew Barth | 302592f | 2016-08-16 16:51:35 -0500 | [diff] [blame] | 26 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 27 | FILES_${PN}-dev_append = " ${libdir}/host-ipmid/lib*${SOLIBSDEV} ${libdir}/host-ipmid/*.la" |
Brad Bishop | 3b524cf | 2016-09-06 13:03:39 -0400 | [diff] [blame] | 28 | |
| 29 | DBUS_SERVICE_${PN} += "org.openbmc.HostServices.service" |
Andrew Geissler | afc510f | 2017-01-04 11:11:50 -0600 | [diff] [blame] | 30 | |
| 31 | # Soft Power Off |
| 32 | RDEPENDS_${PN} += "phosphor-mapper" |
| 33 | |
| 34 | TMPL = "op-stop-host@.service" |
| 35 | INSTFMT = "op-stop-host@{0}.service" |
| 36 | TGTFMT = "obmc-stop-host@{0}.target" |
| 37 | FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}" |
| 38 | |
| 39 | SYSTEMD_SERVICE_${PN} += "${TMPL}" |
| 40 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}" |