blob: 2188f043a6168d7ded36249bb0d890fa8e0a9262 [file] [log] [blame]
Deepak Kodihalli5b183e02017-02-20 04:55:20 -06001SUMMARY = "FRU properties config for ipmi-fru-parser"
2PR = "r1"
3
4inherit native
5inherit obmc-phosphor-license
6inherit phosphor-ipmi-fru
7
8SRC_URI += "file://config.yaml"
9
10DEPENDS += " \
11 mrw-native \
12 mrw-perl-tools-native \
13 "
14
15PROVIDES += "virtual/phosphor-ipmi-fru-properties"
16
17S = "${WORKDIR}"
18
19do_install() {
20 DEST=${D}${properties_datadir}
21 install -d ${DEST}
22
23 ${bindir}/perl-native/perl \
24 ${bindir}/gen_fru_properties.pl \
25 -m ${datadir}/obmc-mrw/${MACHINE}.xml \
26 -c config.yaml \
27 -o ${DEST}/out.yaml
28}