Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 1 | # Common code for Phosphor OpenBMC systemd services. |
| 2 | |
| 3 | inherit systemd |
| 4 | |
Patrick Williams | cdcbd5a | 2015-10-15 15:50:00 -0500 | [diff] [blame] | 5 | SYSTEMD_SERVICE_${PN} = "${BPN}.service" |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 6 | SRC_URI += " \ |
Patrick Williams | cdcbd5a | 2015-10-15 15:50:00 -0500 | [diff] [blame] | 7 | file://${BPN}.service \ |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 8 | " |
| 9 | |
| 10 | do_install_append() { |
| 11 | # install systemd unit files |
| 12 | install -d ${D}${systemd_unitdir}/system |
Patrick Williams | cdcbd5a | 2015-10-15 15:50:00 -0500 | [diff] [blame] | 13 | install -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_unitdir}/system |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 14 | } |