Deepak Kodihalli | 394e867 | 2019-10-14 01:23:27 -0500 | [diff] [blame] | 1 | SUMMARY = "PLDM Stack" |
| 2 | DESCRIPTION = "Implementation of the PLDM specifications" |
| 3 | PR = "r1" |
| 4 | PV = "1.0+git${SRCPV}" |
| 5 | |
| 6 | inherit meson pkgconfig |
Deepak Kodihalli | 127d897 | 2020-06-22 05:25:35 -0500 | [diff] [blame] | 7 | inherit systemd |
Deepak Kodihalli | 394e867 | 2019-10-14 01:23:27 -0500 | [diff] [blame] | 8 | |
| 9 | require pldm.inc |
| 10 | |
| 11 | DEPENDS += "systemd" |
Matt Spinler | 6fd86c4 | 2020-01-20 14:09:47 -0600 | [diff] [blame] | 12 | DEPENDS += "sdeventplus" |
Deepak Kodihalli | 394e867 | 2019-10-14 01:23:27 -0500 | [diff] [blame] | 13 | DEPENDS += "phosphor-dbus-interfaces" |
| 14 | DEPENDS += "nlohmann-json" |
Deepak Kodihalli | 394e867 | 2019-10-14 01:23:27 -0500 | [diff] [blame] | 15 | DEPENDS += "cli11" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
Deepak Kodihalli | 127d897 | 2020-06-22 05:25:35 -0500 | [diff] [blame] | 19 | SYSTEMD_SERVICE_${PN} += "pldmd.service" |
Chicago Duan | 4236597 | 2020-08-27 15:07:55 +0800 | [diff] [blame] | 20 | SYSTEMD_SERVICE_${PN} += "pldmSoftPowerOff.service" |
Deepak Kodihalli | 127d897 | 2020-06-22 05:25:35 -0500 | [diff] [blame] | 21 | |
Deepak Kodihalli | 394e867 | 2019-10-14 01:23:27 -0500 | [diff] [blame] | 22 | EXTRA_OEMESON = " \ |
| 23 | -Dtests=disabled \ |
| 24 | -Doem-ibm=disabled \ |
| 25 | " |
Andrew Geissler | 5e124cd | 2020-10-28 16:43:35 -0500 | [diff] [blame] | 26 | |
| 27 | # Install pldmSoftPowerOff.service in correct targets |
| 28 | pkg_postinst_${PN} () { |
| 29 | |
| 30 | mkdir -p $D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires |
| 31 | LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/pldmSoftPowerOff.service" |
| 32 | TARGET="../pldmSoftPowerOff.service" |
| 33 | ln -s $TARGET $LINK |
| 34 | |
Andrew Geissler | dfa2d6b | 2020-12-09 16:03:36 -0600 | [diff] [blame] | 35 | mkdir -p $D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants |
| 36 | LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/pldmSoftPowerOff.service" |
| 37 | TARGET="../pldmSoftPowerOff.service" |
| 38 | ln -s $TARGET $LINK |
| 39 | |
Andrew Geissler | 5e124cd | 2020-10-28 16:43:35 -0500 | [diff] [blame] | 40 | mkdir -p $D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires |
| 41 | LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/pldmSoftPowerOff.service" |
| 42 | TARGET="../pldmSoftPowerOff.service" |
| 43 | ln -s $TARGET $LINK |
| 44 | } |
| 45 | |
| 46 | pkg_prerm_${PN} () { |
| 47 | |
| 48 | LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/pldmSoftPowerOff.service" |
| 49 | rm $LINK |
| 50 | |
Andrew Geissler | dfa2d6b | 2020-12-09 16:03:36 -0600 | [diff] [blame] | 51 | LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/pldmSoftPowerOff.service" |
| 52 | rm $LINK |
| 53 | |
Andrew Geissler | 5e124cd | 2020-10-28 16:43:35 -0500 | [diff] [blame] | 54 | LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/pldmSoftPowerOff.service" |
| 55 | rm $LINK |
| 56 | } |