blob: 02f4514e4cc16d80ba58db45d44e9d954fe12e13 [file] [log] [blame]
Deepak Kodihalli5b183e02017-02-20 04:55:20 -06001SUMMARY = "FRU properties config for ipmi-fru-parser"
2PR = "r1"
Patrick Venture59157a02018-11-03 16:35:10 -07003LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
Deepak Kodihalli5b183e02017-02-20 04:55:20 -06005
6inherit native
Deepak Kodihalli5b183e02017-02-20 04:55:20 -06007inherit phosphor-ipmi-fru
8
Ratan Guptadccf5ad2017-03-30 14:32:02 +05309SRC_URI += "file://extra-properties.yaml"
Deepak Kodihalli5b183e02017-02-20 04:55:20 -060010
11PROVIDES += "virtual/phosphor-ipmi-fru-properties"
12
13S = "${WORKDIR}"
14
15do_install() {
16 # This recipe is supposed to create an output yaml file with
17 # FRU property values extracted from the MRW. This example recipe
18 # provides a sample output file.
19
20 DEST=${D}${properties_datadir}
21 install -d ${DEST}
Ratan Guptadccf5ad2017-03-30 14:32:02 +053022 install extra-properties.yaml ${DEST}
Deepak Kodihalli5b183e02017-02-20 04:55:20 -060023}