Brad Bishop | 6f75a62 | 2019-02-04 14:28:33 -0500 | [diff] [blame] | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
| 2 | |
| 3 | SRC_URI += " file://pam.d/common-password \ |
| 4 | file://pam.d/common-account \ |
| 5 | file://pam.d/common-auth \ |
Richard Marian Thomaiyar | 15a293b | 2019-11-02 21:24:29 +0530 | [diff] [blame] | 6 | file://pam.d/common-session \ |
Brad Bishop | 6f75a62 | 2019-02-04 14:28:33 -0500 | [diff] [blame] | 7 | " |
| 8 | |
| 9 | RDEPENDS_${PN}-runtime += "${MLPREFIX}pam-plugin-cracklib-${libpam_suffix} \ |
| 10 | ${MLPREFIX}pam-plugin-tally2-${libpam_suffix} \ |
| 11 | ${MLPREFIX}pam-plugin-pwhistory-${libpam_suffix} \ |
Richard Marian Thomaiyar | 8c65b60 | 2020-01-28 15:02:37 +0530 | [diff] [blame] | 12 | ${MLPREFIX}pam-plugin-succeed-if-${libpam_suffix} \ |
Richard Marian Thomaiyar | 4f3be3a | 2020-05-28 11:07:18 +0530 | [diff] [blame] | 13 | ${MLPREFIX}pam-plugin-localuser-${libpam_suffix} \ |
Brad Bishop | 6f75a62 | 2019-02-04 14:28:33 -0500 | [diff] [blame] | 14 | " |
| 15 | |
Matt Spinler | 3457266 | 2018-10-16 11:32:13 -0500 | [diff] [blame] | 16 | do_install_append() { |
| 17 | # The libpam recipe will always add a pam_systemd.so line to |
| 18 | # common-session if systemd is enabled; however systemd only |
| 19 | # builds pam_systemd.so if logind is enabled, and we disable |
| 20 | # that package. So, remove the pam_systemd.so line here. |
| 21 | sed -i '/pam_systemd.so/d' ${D}${sysconfdir}/pam.d/common-session |
| 22 | } |