blob: 9d3315cf5302b442c5c8ccf8cf264dc3cbdf6c8f [file] [log] [blame]
Jeremy Kerr49208ee2016-03-17 17:35:27 +08001SUMMARY = "OpenBMC console daemon"
2DESCRIPTION = "Daemon to handle UART console connections"
3HOMEPAGE = "http://github.com/openbmc/obmc-console"
4PR = "r1"
5
6inherit obmc-phosphor-license
7inherit obmc-phosphor-systemd
8inherit autotools
Ratan Gupta653779c2016-10-01 14:57:15 -05009inherit obmc-phosphor-discovery-service
Jeremy Kerr49208ee2016-03-17 17:35:27 +080010
11TARGET_CFLAGS += "-fpic -O2"
12
Matthew Barth3cc6f402016-09-26 16:26:27 -050013DEPENDS += "autoconf-archive-native"
14
Jeremy Kerr49208ee2016-03-17 17:35:27 +080015SRC_URI += "git://github.com/openbmc/obmc-console"
Brad Bishop530eb732016-08-30 14:14:24 -040016SRC_URI += "file://${PN}.conf"
Jeremy Kerred9fafd2016-04-12 13:10:12 +080017
Patrick Williams9f3cc922016-09-28 08:00:04 -050018SRCREV = "44580de4e2170c8ee06dbf401315d3acfcf52b22"
Jeremy Kerr49208ee2016-03-17 17:35:27 +080019
Ratan Gupta653779c2016-10-01 14:57:15 -050020REGISTERED_SERVICES_${PN} += "obmc_console:tcp:2200"
Vishwanatha Subbanna5f3a19b2016-10-01 11:34:42 -050021OBMC_CONSOLE_HOST_TTY ?= "ttyVUART0"
22SYSTEMD_SUBSTITUTIONS += "OBMC_CONSOLE_HOST_TTY:${OBMC_CONSOLE_HOST_TTY}:${PN}-ssh@.service"
Ratan Gupta653779c2016-10-01 14:57:15 -050023
Brad Bishop530eb732016-08-30 14:14:24 -040024SYSTEMD_SERVICE_${PN} = " \
Vishwanatha Subbanna5f3a19b2016-10-01 11:34:42 -050025 ${PN}@.service \
26 ${PN}@${OBMC_CONSOLE_HOST_TTY}.service \
Brad Bishop530eb732016-08-30 14:14:24 -040027 ${PN}-ssh.socket \
28 ${PN}-ssh@.service \
29 "
Jeremy Kerr49208ee2016-03-17 17:35:27 +080030do_install_append() {
31 install -m 0755 -d ${D}${sysconfdir}
32 install -m 0644 ${WORKDIR}/${PN}.conf ${D}${sysconfdir}/${PN}.conf
Jeremy Kerr49208ee2016-03-17 17:35:27 +080033}
34
35S = "${WORKDIR}/git"