blob: 1b88a2f9d012c4cbcca14b689de7f9e0e20b7d75 [file] [log] [blame]
Patrick Williamsf6f2edb2017-01-30 11:05:56 -06001SUMMARY = "Phosphor DBus Interfaces"
2DESCRIPTION = "Generated bindings, using sdbus++, for the phosphor YAML"
3PR = "r1"
4
5S = "${WORKDIR}/git"
6
7inherit autotools pkgconfig
8inherit obmc-phosphor-license
9inherit pythonnative
10
11DEPENDS += "autoconf-archive-native"
Brad Bishop5f7b1712017-02-02 20:49:22 -050012DEPENDS += "sdbus++-native"
Patrick Williamsf6f2edb2017-01-30 11:05:56 -060013
Brad Bishop5f7b1712017-02-02 20:49:22 -050014PACKAGE_BEFORE_PN = "${PN}-yaml"
15
16FILES_${PN}-yaml = "${datadir}/${PN}/yaml"
Patrick Williamsf6f2edb2017-01-30 11:05:56 -060017
18SRC_URI += "git://github.com/openbmc/phosphor-dbus-interfaces"
Patrick Williams404b7aa2017-02-09 05:50:03 -060019SRCREV = "06e5b23a3671f44c04c7f7cce83def5ff68c86b9"
Brad Bishop5f7b1712017-02-02 20:49:22 -050020
21DEPENDS_remove_class-native = "sdbus++-native"
22DEPENDS_remove_class-nativesdk = "sdbus++-native"
23
24PACKAGECONFIG ??= "libphosphor_dbus"
25PACKAGECONFIG[libphosphor_dbus] = "--enable-libphosphor_dbus,--disable-libphosphor_dbus,sdbusplus,libsystemd"
26
27PACKAGECONFIG_remove_class-native = "libphosphor_dbus"
28PACKAGECONFIG_remove_class-nativesdk = "libphosphor_dbus"
29
30BBCLASSEXTEND += "native nativesdk"