blob: b8911aa53733c32fdc211461af941029a1a077b9 [file] [log] [blame]
Brad Bishop86ee1cf2016-06-27 14:53:52 -04001SUMMARY = "OpenBMC python devtools"
2DESCRIPTION = "Shortcut scripts for developers."
3PR = "r1"
4
5inherit skeleton-python
6
7VIRTUAL-RUNTIME_skeleton_workbook ?= ""
8
9RDEPENDS_${PN} += "\
10 python-dbus \
11 python-json \
12 python-xml \
13 python-pygobject \
14 ${VIRTUAL-RUNTIME_skeleton_workbook} \
15 "
16
17SKELETON_DIR = "pytools"
Andrew Jefferye6e3f462018-02-26 11:25:27 +103018
19do_install_append() {
20 if [ -f ${S}/obmcutil-completion.sh ]
21 then
Brad Bishopd1413ae2018-03-01 16:21:40 -050022 install -d ${D}${sysconfdir}/profile.d
23 install -m 0644 -D -t ${D}${sysconfdir}/profile.d ${S}/obmcutil-completion.sh
Andrew Jefferye6e3f462018-02-26 11:25:27 +103024 fi
25}