Marri Devender Rao | 5a0088c | 2017-07-26 02:11:32 -0500 | [diff] [blame] | 1 | SUMMARY = "To merge the Host and BMC config files generated from MRW " |
Nagaraju Goruganti | 5851dc1 | 2018-04-01 07:56:47 -0500 | [diff] [blame] | 2 | DESCRIPTION = "Merge host provided FRU info config file, fru info config, \ |
| 3 | which is not sent by host config, and BMC accessible FRU info config \ |
| 4 | files generated by gen-ipmi-fru.pl into a single config file. \ |
| 5 | fru-gen parser parses the merged config file and generates cpp file" |
Marri Devender Rao | 5a0088c | 2017-07-26 02:11:32 -0500 | [diff] [blame] | 6 | PR = "r1" |
| 7 | |
| 8 | inherit native |
| 9 | inherit phosphor-ipmi-host |
| 10 | inherit obmc-phosphor-license |
| 11 | |
| 12 | DEPENDS += "virtual/phosphor-ipmi-fru-read-inventory" |
| 13 | DEPENDS += "virtual/phosphor-ipmi-fru-read-bmc-inventory" |
Nagaraju Goruganti | 5851dc1 | 2018-04-01 07:56:47 -0500 | [diff] [blame] | 14 | DEPENDS += "virtual/phosphor-ipmi-fru-read-not-sent-by-host-inventory" |
Marri Devender Rao | 5a0088c | 2017-07-26 02:11:32 -0500 | [diff] [blame] | 15 | PROVIDES += "virtual/phosphor-ipmi-fru-merge-config" |
| 16 | |
| 17 | do_install_append() { |
| 18 | SRC=${config_datadir} |
| 19 | DEST=${D}${config_datadir} |
| 20 | install -d ${DEST} |
| 21 | cat ${SRC}/config.yaml ${SRC}/bmc-fru-config.yaml > ${DEST}/fru_config.yaml |
Nagaraju Goruganti | 5851dc1 | 2018-04-01 07:56:47 -0500 | [diff] [blame] | 22 | cat ${SRC}/fru-config-not-sent-by-host.yaml >> ${DEST}/fru_config.yaml |
Marri Devender Rao | 5a0088c | 2017-07-26 02:11:32 -0500 | [diff] [blame] | 23 | } |