Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 1 | SUMMARY = "Phosphor Mapper Configuration" |
| 2 | DESCRIPTION = "Meta-recipe, pulling in native recipes that wish to add \ |
| 3 | configuration files to the native /usr/share/phosphor-mapper filesystem." |
| 4 | HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr" |
| 5 | PR = "r1" |
Patrick Venture | 9d6b2d1 | 2018-11-03 14:28:21 -0700 | [diff] [blame] | 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658" |
Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 8 | |
Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 9 | inherit native |
| 10 | inherit phosphor-mapper |
| 11 | |
| 12 | PHOSPHOR_MAPPER_CONFIGS = " \ |
| 13 | phosphor-dbus-interfaces-mapper-config-native \ |
| 14 | phosphor-legacy-namespace-mapper-config-native \ |
| 15 | " |
| 16 | |
| 17 | DEPENDS += "${PHOSPHOR_MAPPER_CONFIGS}" |
| 18 | |
| 19 | # To add namespaces and blacklists to the mapper configuration, |
| 20 | # create a native recipe in your layer, and add it to |
| 21 | # PHOSPHOR_MAPPER_CONFIGS with a bbappend to this recipe. |
| 22 | # Recipes should set one of the variables below. |
| 23 | # Consult phosphor-mapper.bbclass for additional information. |
| 24 | |
Brad Bishop | 385c63f | 2018-10-22 20:48:49 -0400 | [diff] [blame] | 25 | # Add services to be monitored. |
| 26 | PHOSPHOR_MAPPER_SERVICE = "" |
| 27 | |
Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 28 | # Add interfaces to be monitored. |
| 29 | PHOSPHOR_MAPPER_INTERFACE = "" |
| 30 | |
Brad Bishop | 385c63f | 2018-10-22 20:48:49 -0400 | [diff] [blame] | 31 | # Blacklist services from being monitored. |
| 32 | PHOSPHOR_MAPPER_SERVICE_BLACKLIST = "" |
| 33 | |
Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 34 | do_install() { |
| 35 | install -d ${D}/${namespace_dir} |
| 36 | install -d ${D}/${interface_dir} |
Brad Bishop | 385c63f | 2018-10-22 20:48:49 -0400 | [diff] [blame] | 37 | install -d ${D}/${serviceblacklist_dir} |
Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 38 | } |