Brad Bishop | ce08674 | 2015-10-27 17:12:45 -0400 | [diff] [blame] | 1 | SUMMARY = "Phosphor DBUS Object Manager" |
| 2 | DESCRIPTION = "Phosphor DBUS object manager." |
| 3 | HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr" |
| 4 | PR = "r1" |
Patrick Venture | 90b2a3f | 2018-10-05 15:08:31 -0700 | [diff] [blame] | 5 | PV = "1.0+git${SRCPV}" |
Brad Bishop | ce08674 | 2015-10-27 17:12:45 -0400 | [diff] [blame] | 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc" |
| 8 | |
Matthew Barth | e997291 | 2016-10-05 16:20:54 -0500 | [diff] [blame] | 9 | inherit autotools pkgconfig |
Matthew Barth | 67cb5a5 | 2016-11-16 10:17:02 -0600 | [diff] [blame] | 10 | inherit obmc-phosphor-python-autotools |
Brad Bishop | ce08674 | 2015-10-27 17:12:45 -0400 | [diff] [blame] | 11 | inherit obmc-phosphor-dbus-service |
| 12 | inherit obmc-phosphor-systemd |
Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 13 | inherit phosphor-mapperdir |
Brad Bishop | ce08674 | 2015-10-27 17:12:45 -0400 | [diff] [blame] | 14 | |
Brad Bishop | 48b1961 | 2016-08-07 23:18:32 -0400 | [diff] [blame] | 15 | DEPENDS += "systemd" |
Matthew Barth | e997291 | 2016-10-05 16:20:54 -0500 | [diff] [blame] | 16 | DEPENDS += "autoconf-archive-native" |
Andrew Geissler | 9ece75f | 2018-10-02 20:40:17 +0000 | [diff] [blame] | 17 | DEPENDS += "boost" |
| 18 | DEPENDS += "libtinyxml2" |
Matt Spinler | 1b556ae | 2017-06-08 12:35:36 -0500 | [diff] [blame] | 19 | DEPENDS += "sdbusplus" |
| 20 | DEPENDS += "phosphor-logging" |
Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 21 | DEPENDS += "${PN}-config-native" |
Rick Altherr | c38aae0 | 2016-08-01 14:20:50 -0700 | [diff] [blame] | 22 | |
Brad Bishop | 7476cd1 | 2016-11-02 15:21:22 -0400 | [diff] [blame] | 23 | DBUS_SERVICE_${PN} += "xyz.openbmc_project.ObjectMapper.service" |
Adriana Kobylak | 545f874 | 2017-04-11 11:06:59 -0500 | [diff] [blame] | 24 | SYSTEMD_SERVICE_${PN} += " \ |
| 25 | mapper-wait@.service \ |
| 26 | mapper-subtree-remove@.service \ |
| 27 | " |
Matthew Barth | e997291 | 2016-10-05 16:20:54 -0500 | [diff] [blame] | 28 | RDEPENDS_libmapper += "libsystemd" |
Brad Bishop | ce08674 | 2015-10-27 17:12:45 -0400 | [diff] [blame] | 29 | RDEPENDS_${PN} += " \ |
Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 30 | python-argparse \ |
Brad Bishop | ce08674 | 2015-10-27 17:12:45 -0400 | [diff] [blame] | 31 | python-xml \ |
| 32 | python-dbus \ |
| 33 | python-pygobject \ |
Patrick Williams | fee2582 | 2017-03-03 12:52:30 -0600 | [diff] [blame] | 34 | pyphosphor-dbus \ |
Patrick Venture | be3afaa | 2017-07-31 10:52:27 -0700 | [diff] [blame] | 35 | pyphosphor-utils \ |
Matt Spinler | 1b556ae | 2017-06-08 12:35:36 -0500 | [diff] [blame] | 36 | sdbusplus \ |
| 37 | phosphor-logging \ |
Brad Bishop | ce08674 | 2015-10-27 17:12:45 -0400 | [diff] [blame] | 38 | " |
Chris Austen | 350def1 | 2015-12-02 22:32:06 -0600 | [diff] [blame] | 39 | SRC_URI += "git://github.com/openbmc/phosphor-objmgr" |
Brad Bishop | ce08674 | 2015-10-27 17:12:45 -0400 | [diff] [blame] | 40 | |
Andrew Geissler | 9042a2d | 2018-12-05 14:30:21 +0000 | [diff] [blame] | 41 | SRCREV = "47c09755e5a7e4c998ed9c4e82d82f7ee5cd6f43" |
Brad Bishop | ce08674 | 2015-10-27 17:12:45 -0400 | [diff] [blame] | 42 | |
| 43 | S = "${WORKDIR}/git" |
Brad Bishop | 9a701b4 | 2016-07-26 15:52:01 -0400 | [diff] [blame] | 44 | |
Brad Bishop | 9a701b4 | 2016-07-26 15:52:01 -0400 | [diff] [blame] | 45 | python populate_packages_prepend () { |
| 46 | mapperlibdir = d.getVar("libdir", True) |
| 47 | do_split_packages(d, mapperlibdir, '^lib(.*)\.so\.*', 'lib%s', 'Phosphor mapper %s library', extra_depends='', allow_links=True) |
| 48 | } |
| 49 | PACKAGES_DYNAMIC += "^libmapper.*" |
| 50 | FILES_${PN}_remove = "${libdir}/lib*.so.* ${libdir}/*" |
Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 51 | |
| 52 | # Construct a systemd environment file with mapper commandline |
| 53 | # from the native sysroot /usr/share/phosphor-mapper filesystem. |
| 54 | python do_emit_env() { |
| 55 | path = d.getVar('STAGING_DIR_NATIVE', True) + \ |
Brad Bishop | 385c63f | 2018-10-22 20:48:49 -0400 | [diff] [blame] | 56 | d.getVar('service_dir', True) |
| 57 | services = [] |
| 58 | for s in os.listdir(path): |
| 59 | services.append('.'.join(s.split('-'))) |
| 60 | |
| 61 | path = d.getVar('STAGING_DIR_NATIVE', True) + \ |
Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 62 | d.getVar('interface_dir', True) |
| 63 | interfaces = [] |
| 64 | for i in os.listdir(path): |
| 65 | interfaces.append('.'.join(i.split('-'))) |
| 66 | |
Brad Bishop | 385c63f | 2018-10-22 20:48:49 -0400 | [diff] [blame] | 67 | path = d.getVar('STAGING_DIR_NATIVE', True) + \ |
| 68 | d.getVar('serviceblacklist_dir', True) |
| 69 | service_blacklists = [] |
| 70 | for x in os.listdir(path): |
| 71 | service_blacklists.append('.'.join(x.split('-'))) |
| 72 | |
Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 73 | path = [d.getVar('D', True) + d.getVar('envfiledir', True)] |
| 74 | path.append('obmc') |
| 75 | path.append('mapper') |
| 76 | parent = os.path.join(*path[:-1]) |
| 77 | path = os.path.join(*path) |
| 78 | |
| 79 | if not os.path.exists(parent): |
| 80 | os.makedirs(parent) |
| 81 | with open(path, 'w+') as fd: |
Brad Bishop | 385c63f | 2018-10-22 20:48:49 -0400 | [diff] [blame] | 82 | fd.write('MAPPER_SERVICES="{}"'.format(' '.join(services))) |
| 83 | fd.write('\n') |
Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 84 | fd.write('MAPPER_INTERFACES="{}"'.format(' '.join(interfaces))) |
| 85 | fd.write('\n') |
Brad Bishop | 385c63f | 2018-10-22 20:48:49 -0400 | [diff] [blame] | 86 | fd.write('MAPPER_SERVICEBLACKLISTS="{}"'.format(' '.join(service_blacklists))) |
| 87 | fd.write('\n') |
Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 88 | } |
| 89 | |
| 90 | do_install[postfuncs] += "do_emit_env" |