blob: c952f6eaaa7321ba3e8a14f0785b32b7dc96b742 [file] [log] [blame]
Brad Bishopce086742015-10-27 17:12:45 -04001SUMMARY = "Phosphor DBUS Object Manager"
2DESCRIPTION = "Phosphor DBUS object manager."
3HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
7
Matthew Barthe9972912016-10-05 16:20:54 -05008inherit autotools pkgconfig
Matthew Barth67cb5a52016-11-16 10:17:02 -06009inherit obmc-phosphor-python-autotools
Brad Bishopce086742015-10-27 17:12:45 -040010inherit obmc-phosphor-dbus-service
11inherit obmc-phosphor-systemd
Brad Bishopce086742015-10-27 17:12:45 -040012
Brad Bishop48b19612016-08-07 23:18:32 -040013DEPENDS += "systemd"
Matthew Barthe9972912016-10-05 16:20:54 -050014DEPENDS += "autoconf-archive-native"
Rick Altherrc38aae02016-08-01 14:20:50 -070015
Brad Bishopa5983c92016-08-16 09:40:10 -040016DBUS_SERVICE_${PN} += "org.openbmc.ObjectMapper.service"
Brad Bishop231230b2016-08-08 20:04:29 -040017SYSTEMD_SERVICE_${PN} = "mapper-wait@.service"
Matthew Barthe9972912016-10-05 16:20:54 -050018RDEPENDS_libmapper += "libsystemd"
Brad Bishopce086742015-10-27 17:12:45 -040019RDEPENDS_${PN} += " \
20 python-xml \
21 python-dbus \
22 python-pygobject \
23 "
Chris Austen350def12015-12-02 22:32:06 -060024SRC_URI += "git://github.com/openbmc/phosphor-objmgr"
Brad Bishopce086742015-10-27 17:12:45 -040025
Matthew Barthe9972912016-10-05 16:20:54 -050026SRCREV = "7122244c83092499dc8d7836da0a63a08c734856"
Brad Bishopce086742015-10-27 17:12:45 -040027
28S = "${WORKDIR}/git"
Brad Bishop9a701b42016-07-26 15:52:01 -040029
Brad Bishop9a701b42016-07-26 15:52:01 -040030python populate_packages_prepend () {
31 mapperlibdir = d.getVar("libdir", True)
32 do_split_packages(d, mapperlibdir, '^lib(.*)\.so\.*', 'lib%s', 'Phosphor mapper %s library', extra_depends='', allow_links=True)
33}
34PACKAGES_DYNAMIC += "^libmapper.*"
35FILES_${PN}_remove = "${libdir}/lib*.so.* ${libdir}/*"