Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 1 | SUMMARY = "org.openbmc.control.Host implementation for OpenPOWER" |
| 2 | DESCRIPTION = "A host control implementation suitable for OpenPOWER systems." |
| 3 | PR = "r1" |
Patrick Venture | 6188642 | 2018-10-09 20:20:36 -0700 | [diff] [blame] | 4 | PV = "1.0+git${SRCPV}" |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 5 | |
| 6 | inherit skeleton-gdbus |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 7 | inherit obmc-phosphor-dbus-service |
Brad Bishop | 09523bb | 2018-01-26 21:30:17 -0500 | [diff] [blame] | 8 | inherit pkgconfig |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 9 | |
Sergey Solomin | 7df1936 | 2016-11-28 15:03:24 -0600 | [diff] [blame] | 10 | PROVIDES += "virtual/obmc-host-ctl" |
| 11 | RPROVIDES_${PN} += "virtual-obmc-host-ctl" |
| 12 | |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 13 | SKELETON_DIR = "op-hostctl" |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 14 | |
| 15 | FMT = "org.openbmc.control.Host@{0}.service" |
| 16 | DBUS_SERVICE_${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}" |
Andrew Geissler | 3a20659 | 2017-03-23 12:48:06 -0500 | [diff] [blame] | 17 | SYSTEMD_SERVICE_${PN} = " \ |
| 18 | op-start-host@.service \ |
Andrew Geissler | 3a20659 | 2017-03-23 12:48:06 -0500 | [diff] [blame] | 19 | " |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 20 | |
| 21 | START_TMPL = "op-start-host@.service" |
Lei YU | 21c63b4 | 2018-05-25 11:41:46 +0800 | [diff] [blame] | 22 | START_TGTFMT = "obmc-host-startmin@{1}.target" |
| 23 | START_INSTFMT = "op-start-host@{0}.service" |
Andrew Geissler | a31fba5 | 2017-02-08 15:54:25 -0600 | [diff] [blame] | 24 | START_FMT = "../${START_TMPL}:${START_TGTFMT}.requires/${START_INSTFMT}" |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 25 | |
| 26 | SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'START_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}" |