blob: 5ae3d96640ebaea49c9d2a2ceca3f0758b2bb350 [file] [log] [blame]
Lei YU4d8175e2019-10-21 10:39:07 +08001SUMMARY = "Phosphor Power services and utilities"
2DESCRIPTION = "Configure and monitor power supplies, power sequencers, and \
3voltage regulators, and analyzes power devices for faults"
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6
7inherit meson
8inherit pkgconfig
9inherit systemd
10inherit pythonnative
11
12require ${PN}.inc
13
14S = "${WORKDIR}/git"
15
16# TODO: in future when openpower-dbus-interfaces is removed from
17# phosphor-power, remove the dependency here.
18DEPENDS += " \
19 phosphor-logging \
20 openpower-dbus-interfaces \
21 sdbus++-native \
22 sdeventplus \
23 nlohmann-json \
Jim Wright7a0e57f2019-11-06 15:43:43 -060024 cli11 \
Matthew Barth16867e42019-12-20 15:37:07 -060025 i2c-tools \
Lei YU4d8175e2019-10-21 10:39:07 +080026 "
27
28SEQ_MONITOR_SVC = "pseq-monitor.service"
29SEQ_PGOOD_SVC = "pseq-monitor-pgood.service"
30PSU_MONITOR_TMPL = "power-supply-monitor@.service"
31SYSTEMD_SERVICE_${PN} += "${SEQ_MONITOR_SVC} ${SEQ_PGOOD_SVC} ${PSU_MONITOR_TMPL}"