Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 1 | SUMMARY = "org.openbmc.control.Host implementation for OpenPOWER" |
| 2 | DESCRIPTION = "A host control implementation suitable for OpenPOWER systems." |
| 3 | PR = "r1" |
| 4 | |
| 5 | inherit skeleton-gdbus |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 6 | inherit obmc-phosphor-dbus-service |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 7 | |
Sergey Solomin | 7df1936 | 2016-11-28 15:03:24 -0600 | [diff] [blame] | 8 | PROVIDES += "virtual/obmc-host-ctl" |
| 9 | RPROVIDES_${PN} += "virtual-obmc-host-ctl" |
| 10 | |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 11 | SKELETON_DIR = "op-hostctl" |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 12 | |
| 13 | FMT = "org.openbmc.control.Host@{0}.service" |
| 14 | DBUS_SERVICE_${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}" |
| 15 | SYSTEMD_SERVICE_${PN} = "op-start-host@.service" |
| 16 | |
| 17 | START_TMPL = "op-start-host@.service" |
| 18 | START_TGTFMT = "obmc-chassis-start@{1}.target" |
| 19 | START_INSTFMT = "obmc-start-host@{0}.service" |
Andrew Geissler | a31fba5 | 2017-02-08 15:54:25 -0600 | [diff] [blame] | 20 | START_FMT = "../${START_TMPL}:${START_TGTFMT}.requires/${START_INSTFMT}" |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 21 | |
| 22 | SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'START_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}" |