Patrick Venture | 30823b2 | 2018-03-30 11:23:16 -0700 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC Post Code Daemon" |
| 2 | DESCRIPTION = "Phosphor OpenBMC Post Code Daemon" |
Patrick Venture | a9ac4e5 | 2018-09-28 19:21:26 -0700 | [diff] [blame] | 3 | HOMEPAGE = "http://github.com/openbmc/phosphor-host-postd" |
Patrick Venture | 30823b2 | 2018-03-30 11:23:16 -0700 | [diff] [blame] | 4 | PR = "r1" |
Patrick Venture | a9ac4e5 | 2018-09-28 19:21:26 -0700 | [diff] [blame] | 5 | PV = "0.1+git${SRCPV}" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
Patrick Venture | 30823b2 | 2018-03-30 11:23:16 -0700 | [diff] [blame] | 8 | |
| 9 | inherit autotools pkgconfig |
Patrick Venture | c787422 | 2018-10-23 11:57:36 -0700 | [diff] [blame] | 10 | inherit systemd |
Patrick Venture | 30823b2 | 2018-03-30 11:23:16 -0700 | [diff] [blame] | 11 | |
| 12 | DEPENDS += "autoconf-archive-native" |
| 13 | DEPENDS += "sdbusplus" |
Kun Yi | cf49244 | 2018-09-12 11:01:33 -0700 | [diff] [blame] | 14 | DEPENDS += "sdeventplus" |
Patrick Venture | 30823b2 | 2018-03-30 11:23:16 -0700 | [diff] [blame] | 15 | DEPENDS += "phosphor-dbus-interfaces" |
| 16 | DEPENDS += "systemd" |
| 17 | |
Patrick Venture | a9ac4e5 | 2018-09-28 19:21:26 -0700 | [diff] [blame] | 18 | S = "${WORKDIR}/git" |
| 19 | SRC_URI = "git://github.com/openbmc/phosphor-host-postd" |
Andrew Geissler | 6983837 | 2019-03-29 01:41:47 +0000 | [diff] [blame] | 20 | SRCREV = "49a18b220229304b690097041d8028895bd4215a" |
Patrick Venture | a9ac4e5 | 2018-09-28 19:21:26 -0700 | [diff] [blame] | 21 | |
Benjamin Fair | 8c605cf | 2018-06-29 13:00:14 -0700 | [diff] [blame] | 22 | SNOOP_DEVICE ?= "aspeed-lpc-snoop0" |
| 23 | POST_CODE_BYTES ?= "1" |
| 24 | |
| 25 | SERVICE_FILE = "lpcsnoop.service" |
Patrick Venture | c787422 | 2018-10-23 11:57:36 -0700 | [diff] [blame] | 26 | SYSTEMD_PACKAGES = "${PN}" |
Benjamin Fair | 8c605cf | 2018-06-29 13:00:14 -0700 | [diff] [blame] | 27 | SYSTEMD_SERVICE_${PN} += "${SERVICE_FILE}" |
Patrick Venture | c787422 | 2018-10-23 11:57:36 -0700 | [diff] [blame] | 28 | |
| 29 | EXTRA_OECONF = " \ |
| 30 | SNOOP_DEVICE="${SNOOP_DEVICE}" \ |
| 31 | POST_CODE_BYTES="${POST_CODE_BYTES}" \ |
Patrick Venture | d607cfb | 2019-04-04 12:15:22 -0700 | [diff] [blame] | 32 | SYSTEMD_TARGET="multi-user.target" \ |
Patrick Venture | c787422 | 2018-10-23 11:57:36 -0700 | [diff] [blame] | 33 | " |