Brad Bishop | 8660573 | 2015-11-18 10:56:38 -0500 | [diff] [blame] | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
Brad Bishop | 85e90ff | 2018-06-06 16:16:23 -0400 | [diff] [blame] | 2 | SRC_URI += "file://0001-json-Use-int-long.__str__-to-convert-subclasses.patch" |
Brad Bishop | 8660573 | 2015-11-18 10:56:38 -0500 | [diff] [blame] | 3 | |
Brad Bishop | 8660573 | 2015-11-18 10:56:38 -0500 | [diff] [blame] | 4 | require wsgiref-${PYTHON_MAJMIN}-manifest.inc |
| 5 | |
Brad Bishop | aada156 | 2018-06-07 19:10:54 -0400 | [diff] [blame] | 6 | PROVIDES_prepend = "${PN}-spwd " |
| 7 | PACKAGES_prepend = "${PN}-spwd " |
Brad Bishop | 8660573 | 2015-11-18 10:56:38 -0500 | [diff] [blame] | 8 | |
| 9 | SUMMARY_${PN}-spwd = "Shadow database support" |
| 10 | RDEPENDS_${PN}-spwd = "${PN}-core" |
| 11 | FILES_${PN}-spwd= " \ |
| 12 | ${libdir}/python${PYTHON_MAJMIN}/lib-dynload/spwd.so \ |
| 13 | ${libdir}/python${PYTHON_MAJMIN}/lib-dynload/grp.so \ |
| 14 | " |
Andrew Geissler | 20e22db | 2018-08-29 06:06:42 -0700 | [diff] [blame] | 15 | # Remove all python .py files from python recipe. Only the .pyc |
| 16 | # files are required. Only do this if the openbmc-phosphor-tiny |
| 17 | # distro feature is enabled |
| 18 | do_install_append_openbmc-phosphor-tiny() { |
| 19 | find ${D}${libdir}/python${PYTHON_MAJMIN} -name \*.py -exec rm {} \; |
| 20 | # This is a system configuration file generated during build time. |
| 21 | # It's used in the yocto packaging process so it is required to |
| 22 | # remain in the image. |
| 23 | cp ${WORKDIR}/recipe-sysroot-native/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata.py ${D}${libdir}/python${PYTHON_MAJMIN}/ |
| 24 | } |