Matthew Barth | 3af115f | 2019-06-12 16:17:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Phosphor DBus Monitor Configuration" |
| 2 | DESCRIPTION = "Meta-recipe, pulling in non-native recipes that wish to add \ |
| 3 | configuration files to the /usr/share/phosphor-dbus-monitor filesystem." |
| 4 | HOMEPAGE = "http://github.com/openbmc/phosphor-dbus-monitor" |
| 5 | PR = "r1" |
| 6 | LICENSE = "Apache-2.0" |
Brad Bishop | a1cee09 | 2019-09-13 12:14:05 -0400 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
Matthew Barth | 3af115f | 2019-06-12 16:17:38 -0500 | [diff] [blame] | 8 | |
| 9 | inherit phosphor-dbus-monitor |
| 10 | |
| 11 | PHOSPHOR_DBUS_MONITOR_CONFIGS ??= "" |
| 12 | |
| 13 | # To add additional config files, create a recipe in your layer, |
| 14 | # and add it to PHOSPHOR_DBUS_MONITOR_CONFIGS with a bbappend to this recipe. |
| 15 | |
| 16 | DEPENDS += "${PHOSPHOR_DBUS_MONITOR_CONFIGS}" |
| 17 | |
| 18 | do_install() { |
| 19 | mkdir -p ${D}${config_dir} |
| 20 | } |
| 21 | |
| 22 | FILES_${PN} += "${config_dir}" |