Brad Bishop | 667938f | 2017-01-12 21:44:51 -0500 | [diff] [blame] | 1 | SUMMARY = "OpenBMC - Applications" |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 2 | PR = "r1" |
| 3 | |
| 4 | inherit packagegroup |
| 5 | inherit obmc-phosphor-utils |
| 6 | inherit obmc-phosphor-license |
| 7 | |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 8 | PROVIDES = "${PACKAGES}" |
| 9 | PACKAGES = " \ |
Brad Bishop | 4663170 | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 10 | ${PN}-bmc-state-mgmt \ |
| 11 | ${PN}-chassis-state-mgmt \ |
Brad Bishop | 6165ec3 | 2016-09-06 22:44:21 -0400 | [diff] [blame] | 12 | ${PN}-extras \ |
| 13 | ${PN}-extrasdev \ |
Brad Bishop | 11909e0 | 2017-05-01 11:54:34 -0400 | [diff] [blame] | 14 | ${PN}-fan-control \ |
Brad Bishop | 4663170 | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 15 | ${PN}-host-state-mgmt \ |
Brad Bishop | 45f8b57 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 16 | ${PN}-inventory \ |
| 17 | ${PN}-leds \ |
| 18 | ${PN}-sensors \ |
Gunnar Mills | c868f92 | 2017-02-15 16:01:45 -0600 | [diff] [blame] | 19 | ${PN}-software \ |
Andrew Geissler | a94faf4 | 2017-05-08 15:58:01 -0500 | [diff] [blame] | 20 | ${PN}-host-check-mgmt \ |
Jayanth Othayoth | 9963d17 | 2017-05-08 09:25:05 -0500 | [diff] [blame] | 21 | ${PN}-debug-collector \ |
Deepak Kodihalli | 3e3c88c | 2017-05-17 06:42:51 -0500 | [diff] [blame] | 22 | ${PN}-settings \ |
Ratan Gupta | b6de45c | 2017-07-06 21:09:14 +0530 | [diff] [blame] | 23 | ${PN}-network \ |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 24 | " |
| 25 | |
Brad Bishop | 4663170 | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 26 | SUMMARY_${PN}-bmc-state-mgmt = "BMC state management" |
| 27 | RDEPENDS_${PN}-bmc-state-mgmt = " \ |
| 28 | ${VIRTUAL-RUNTIME_obmc-bmc-state-manager} \ |
| 29 | " |
| 30 | |
| 31 | SUMMARY_${PN}-chassis-state-mgmt = "Chassis state management" |
| 32 | RDEPENDS_${PN}-chassis-state-mgmt = " \ |
| 33 | ${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \ |
| 34 | " |
| 35 | |
Andrew Geissler | a94faf4 | 2017-05-08 15:58:01 -0500 | [diff] [blame] | 36 | SUMMARY_${PN}-host-check-mgmt = "Host state check on bmc reset" |
| 37 | RDEPENDS_${PN}-host-check-mgmt = " \ |
| 38 | ${VIRTUAL-RUNTIME_obmc-host-check} \ |
| 39 | " |
| 40 | |
Brad Bishop | 6165ec3 | 2016-09-06 22:44:21 -0400 | [diff] [blame] | 41 | SUMMARY_${PN}-extras = "Extra features" |
| 42 | RDEPENDS_${PN}-extras = " \ |
Brad Bishop | 667938f | 2017-01-12 21:44:51 -0500 | [diff] [blame] | 43 | phosphor-rest \ |
Brad Bishop | f1cc41b | 2017-05-31 14:08:33 -0400 | [diff] [blame] | 44 | phosphor-dbus-monitor \ |
Brad Bishop | 70436da | 2015-09-16 14:49:27 -0400 | [diff] [blame] | 45 | " |
| 46 | |
Brad Bishop | 6165ec3 | 2016-09-06 22:44:21 -0400 | [diff] [blame] | 47 | SUMMARY_${PN}-extrasdev = "Development features" |
| 48 | RDEPENDS_${PN}-extrasdev = " \ |
Adriana Kobylak | eaa56c9 | 2016-06-16 14:46:06 -0500 | [diff] [blame] | 49 | rest-dbus \ |
| 50 | " |
Brad Bishop | 45f8b57 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 51 | |
Brad Bishop | 11909e0 | 2017-05-01 11:54:34 -0400 | [diff] [blame] | 52 | # Use the fan control package group for applications |
| 53 | # implementing fan control or system fan policy only. |
| 54 | # Applications that create inventory or sensors should |
| 55 | # be added those respective package groups instead. |
| 56 | SUMMARY_${PN}-fan-control = "Fan control" |
| 57 | RDEPENDS_${PN}-fan-control = " \ |
Matt Spinler | bd9fdd9 | 2017-04-19 08:23:50 -0500 | [diff] [blame] | 58 | ${VIRTUAL-RUNTIME_obmc-fan-control} \ |
Matt Spinler | 39652c8 | 2017-05-01 14:29:20 -0500 | [diff] [blame] | 59 | phosphor-fan-monitor \ |
Brad Bishop | 11909e0 | 2017-05-01 11:54:34 -0400 | [diff] [blame] | 60 | " |
| 61 | |
Brad Bishop | 4663170 | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 62 | SUMMARY_${PN}-host-state-mgmt = "Host state management" |
| 63 | RDEPENDS_${PN}-host-state-mgmt = " \ |
| 64 | ${VIRTUAL-RUNTIME_obmc-host-state-manager} \ |
Michael Tritz | 1f792e0 | 2017-03-31 12:04:32 -0500 | [diff] [blame] | 65 | ${VIRTUAL-RUNTIME_obmc-discover-system-state} \ |
Brad Bishop | 4663170 | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 66 | " |
| 67 | |
Brad Bishop | 45f8b57 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 68 | SUMMARY_${PN}-inventory = "Inventory applications" |
| 69 | RDEPENDS_${PN}-inventory = " \ |
| 70 | ${VIRTUAL-RUNTIME_obmc-inventory-manager} \ |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 71 | ${VIRTUAL-RUNTIME_obmc-fan-presence} \ |
Brad Bishop | 45f8b57 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 72 | " |
| 73 | |
| 74 | SUMMARY_${PN}-leds = "LED applications" |
| 75 | RDEPENDS_${PN}-leds = " \ |
Brad Bishop | c1d30c5 | 2017-02-27 11:59:49 -0500 | [diff] [blame] | 76 | ${VIRTUAL-RUNTIME_obmc-leds-manager} \ |
| 77 | ${VIRTUAL-RUNTIME_obmc-leds-sysfs} \ |
Dhruvaraj Subhashchandran | e1266ad | 2017-04-27 05:29:56 -0500 | [diff] [blame] | 78 | ${VIRTUAL-RUNTIME_obmc-led-monitor} \ |
Brad Bishop | 45f8b57 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 79 | " |
| 80 | |
| 81 | SUMMARY_${PN}-sensors = "Sensor applications" |
| 82 | RDEPENDS_${PN}-sensors = " \ |
| 83 | ${VIRTUAL-RUNTIME_obmc-sensors-hwmon} \ |
| 84 | " |
Gunnar Mills | c868f92 | 2017-02-15 16:01:45 -0600 | [diff] [blame] | 85 | |
| 86 | SUMMARY_${PN}-software = "Software applications" |
| 87 | RDEPENDS_${PN}-software = " \ |
Deepak Kodihalli | 60d1de5 | 2017-04-13 23:23:42 -0500 | [diff] [blame] | 88 | ${VIRTUAL-RUNTIME_obmc-bmc-download-mgr} \ |
Gunnar Mills | 30131f7 | 2017-05-15 15:40:58 -0500 | [diff] [blame] | 89 | ${VIRTUAL-RUNTIME_obmc-bmc-updater} \ |
Gunnar Mills | c868f92 | 2017-02-15 16:01:45 -0600 | [diff] [blame] | 90 | " |
Jayanth Othayoth | 9963d17 | 2017-05-08 09:25:05 -0500 | [diff] [blame] | 91 | SUMMARY_${PN}-debug-collector = "BMC debug collector" |
| 92 | RDEPENDS_${PN}-debug-collector = " \ |
Jayanth Othayoth | 9d21d6c | 2017-05-31 06:25:55 -0500 | [diff] [blame] | 93 | ${VIRTUAL-RUNTIME_obmc-dump-manager} \ |
| 94 | ${VIRTUAL-RUNTIME_obmc-dump-monitor} \ |
Jayanth Othayoth | d259249 | 2017-07-29 22:28:44 -0500 | [diff] [blame] | 95 | phosphor-debug-collector-dreport \ |
Vishwanatha Subbanna | 14609cb | 2017-05-12 23:31:55 +0530 | [diff] [blame] | 96 | " |
Deepak Kodihalli | 3e3c88c | 2017-05-17 06:42:51 -0500 | [diff] [blame] | 97 | |
| 98 | SUMMARY_${PN}-settings = "Settings applications" |
| 99 | RDEPENDS_${PN}-settings = " \ |
| 100 | ${VIRTUAL-RUNTIME_obmc-settings-mgr} \ |
| 101 | " |
Ratan Gupta | b6de45c | 2017-07-06 21:09:14 +0530 | [diff] [blame] | 102 | |
| 103 | SUMMARY_${PN}-network = "BMC Network Manager" |
| 104 | RDEPENDS_${PN}-network = " \ |
| 105 | ${VIRTUAL-RUNTIME_obmc-network-manager} \ |
| 106 | " |