Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 1 | # Common code for recipes that modify the phosphor-mapper |
| 2 | # configuration. |
| 3 | # |
| 4 | # Typically it is not desired to monitor all dbus traffic |
| 5 | # on a system and as such, the phosphor-mapper has command |
| 6 | # line options to control what path namespaces and dbus |
| 7 | # interfaces it will keep track of. |
| 8 | # |
| 9 | # The Phosphor layer by default configures the mapper to |
Brad Bishop | 385c63f | 2018-10-22 20:48:49 -0400 | [diff] [blame] | 10 | # watch xyz.openbmc_project services, interfaces and paths |
| 11 | # only. This configuration file is intended to be inherited |
| 12 | # by native recipes in other layers that wish to add namespaces |
Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 13 | # or interfaces to the mapper watchlist. |
| 14 | |
| 15 | # Add path namespaces to be monitored: |
| 16 | # PHOSPHOR_MAPPER_NAMESPACE_append = " /foo/bar" |
| 17 | |
Brad Bishop | 385c63f | 2018-10-22 20:48:49 -0400 | [diff] [blame] | 18 | # Add service namespaces to be monitored: |
| 19 | # PHOSPHOR_MAPPER_SERVICE_append = " foo.bar" |
| 20 | |
Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 21 | # Add interfaces to be monitored: |
| 22 | # PHOSPHOR_MAPPER_INTERFACE_append = " foo.bar" |
| 23 | |
Brad Bishop | 385c63f | 2018-10-22 20:48:49 -0400 | [diff] [blame] | 24 | # Blacklist services from being monitored: |
| 25 | # PHOSPHOR_MAPPER_SERVICE_BLACKLIST_append = " foo.bar" |
| 26 | |
Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 27 | inherit phosphor-mapperdir |
Brad Bishop | 6f120e3 | 2018-03-09 16:51:57 -0500 | [diff] [blame] | 28 | inherit obmc-phosphor-utils |
Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 29 | |
| 30 | python phosphor_mapper_do_postinst() { |
| 31 | def process_var(d, var, dir): |
| 32 | for p in listvar_to_list(d, var): |
| 33 | parent = d.getVar('D', True) + d.getVar(dir, True) |
| 34 | if not os.path.exists(parent): |
| 35 | os.makedirs(parent) |
| 36 | path = os.path.join( |
| 37 | parent, |
Brad Bishop | b4eea30 | 2017-08-03 15:56:09 -0400 | [diff] [blame] | 38 | '-'.join(p.split(os.sep))) |
Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 39 | with open(path, 'w+') as fd: |
| 40 | pass |
| 41 | |
| 42 | process_var(d, 'PHOSPHOR_MAPPER_NAMESPACE', 'namespace_dir') |
Brad Bishop | 385c63f | 2018-10-22 20:48:49 -0400 | [diff] [blame] | 43 | process_var(d, 'PHOSPHOR_MAPPER_SERVICE', 'service_dir') |
Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 44 | process_var(d, 'PHOSPHOR_MAPPER_INTERFACE', 'interface_dir') |
Brad Bishop | 385c63f | 2018-10-22 20:48:49 -0400 | [diff] [blame] | 45 | process_var(d, 'PHOSPHOR_MAPPER_SERVICE_BLACKLIST', 'serviceblacklist_dir') |
Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 46 | } |
| 47 | |
| 48 | do_install[vardeps] += "PHOSPHOR_MAPPER_NAMESPACE" |
Brad Bishop | 385c63f | 2018-10-22 20:48:49 -0400 | [diff] [blame] | 49 | do_install[vardeps] += "PHOSPHOR_MAPPER_SERVICE" |
Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 50 | do_install[vardeps] += "PHOSPHOR_MAPPER_INTERFACE" |
Brad Bishop | 385c63f | 2018-10-22 20:48:49 -0400 | [diff] [blame] | 51 | do_install[vardeps] += "PHOSPHOR_MAPPER_SERVICE_BLACKLIST" |
Brad Bishop | f8a7cd1 | 2017-07-09 23:41:49 -0400 | [diff] [blame] | 52 | do_install[postfuncs] += "phosphor_mapper_do_postinst" |