Vishwanatha Subbanna | 7e84c6e | 2017-01-23 16:04:35 +0530 | [diff] [blame] | 1 | SUMMARY = "Phosphor LED Group Management with MRW generated data" |
| 2 | PR = "r1" |
| 3 | |
| 4 | inherit native |
| 5 | inherit obmc-phosphor-utils |
| 6 | inherit obmc-phosphor-license |
Matt Spinler | 3f6fcbe | 2017-12-14 13:31:55 -0600 | [diff] [blame] | 7 | inherit mrw-xml |
Vishwanatha Subbanna | 7e84c6e | 2017-01-23 16:04:35 +0530 | [diff] [blame] | 8 | |
Vishwanatha Subbanna | 8bec825 | 2017-02-11 22:10:23 +0530 | [diff] [blame] | 9 | PROVIDES += "virtual/phosphor-led-manager-config-native" |
Vishwanatha Subbanna | 7e84c6e | 2017-01-23 16:04:35 +0530 | [diff] [blame] | 10 | DEPENDS += "mrw-native mrw-perl-tools-native" |
| 11 | |
| 12 | # Generate a YAML files based on MRW input |
| 13 | do_install_append() { |
Brad Bishop | 7a17b6b | 2018-03-08 22:29:25 -0500 | [diff] [blame] | 14 | USE_MRW="${@df_enabled(d, 'obmc-mrw', 'yes')}" |
Patrick Williams | e81f8c0 | 2017-02-28 14:28:18 -0600 | [diff] [blame] | 15 | DEST=${D}${datadir}/phosphor-led-manager |
Vishwanatha Subbanna | 7e84c6e | 2017-01-23 16:04:35 +0530 | [diff] [blame] | 16 | |
| 17 | if [ "${USE_MRW}" = "yes" ]; then |
| 18 | install -d ${DEST}/ |
| 19 | ${STAGING_BINDIR_NATIVE}/perl-native/perl \ |
| 20 | ${STAGING_BINDIR_NATIVE}/gen_led_groups.pl \ |
Matt Spinler | 3f6fcbe | 2017-12-14 13:31:55 -0600 | [diff] [blame] | 21 | -i ${mrw_datadir}/${MRW_XML} \ |
Vishwanatha Subbanna | 7e84c6e | 2017-01-23 16:04:35 +0530 | [diff] [blame] | 22 | -o ${DEST}/led.yaml |
| 23 | fi |
| 24 | } |