Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 1 | SUMMARY = "Logging DBUS Object" |
| 2 | DESCRIPTION = "Logging DBUS Object" |
| 3 | HOMEPAGE = "https://github.com/openbmc/phosphor-logging" |
| 4 | PR = "r1" |
| 5 | |
| 6 | inherit autotools pkgconfig |
| 7 | inherit pythonnative |
| 8 | inherit obmc-phosphor-license |
| 9 | inherit obmc-phosphor-dbus-service |
Adriana Kobylak | f40e1d8 | 2017-02-09 13:43:22 -0600 | [diff] [blame] | 10 | inherit phosphor-dbus-interfaces |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 11 | |
| 12 | DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service" |
| 13 | |
| 14 | DEPENDS += "autoconf-archive-native" |
| 15 | DEPENDS += "systemd" |
| 16 | DEPENDS += "python-mako-native" |
| 17 | DEPENDS += "python-pyyaml-native" |
Patrick Williams | 57b1781 | 2016-12-09 08:56:38 -0600 | [diff] [blame] | 18 | DEPENDS += "sdbusplus sdbusplus-native" |
Adriana Kobylak | 7878409 | 2017-02-09 15:06:41 -0600 | [diff] [blame] | 19 | DEPENDS += "phosphor-dbus-interfaces" |
| 20 | RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 21 | PROVIDES += "virtual/obmc-logging-mgmt" |
| 22 | RPROVIDES_${PN} += "virtual-obmc-logging-mgmt" |
| 23 | |
| 24 | SRC_URI += "git://github.com/openbmc/phosphor-logging" |
Patrick Williams | 2f9b97f | 2017-02-24 15:10:03 -0600 | [diff] [blame] | 25 | SRCREV = "23b475a04b61ce1b25dc3ca9c0db04fdfdd415e3" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 26 | |
| 27 | S = "${WORKDIR}/git" |
| 28 | |
Adriana Kobylak | f40e1d8 | 2017-02-09 13:43:22 -0600 | [diff] [blame] | 29 | EXTRA_OECONF = "YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir}" |